Instalowanie *.tar.xz pewnie proste

Zawsze instaluję przez add/remove apps, ale teraz ściągnąłem uaktualnienie i nie wiem jak go dokonać.
Czy ściągnięty plik/folder mam gdzieś wgrać i potem coś zakomendować?

proszę o help!

A co to w ogóle jest?
W Linuksie do instalacji / aktualizowania oprogramowania używamy menedżerów pakietów.
Może warto zaznajomić się z podstawami.

2lajki

To jest pudełko, w ktorym wyszukuję programy, zarządzam nimi, instaluję lub deinst.
Bardzo praktyczne, i chciałbym tak dalej.

Pudełko powiadasz…
To poszukaj manuala do “pudełka”.
Albo kogoś do pomocy posiadającego szklaną kulę.

@Ren co dokładnie próbujesz zainstalować i w jaki sposób? Jeśli to jest program z repozytoriów to po prostu aktualizujesz system w Pamacu albo w konsoli wpisujesz sudo pacman -Syyu. Jeśli to jest Appimage to nadajesz prawa wykonywania i uruchamiasz program – tego się nie aktualizuje, możesz działać zarówno na starej jak i na nowej wersji. A jeśli to jest pakiet .pkg.tar.xz czy pkg.tar.zst (ten drugi to nowy standard) to klikasz i od razu powinieneś przejść do procesu instalacji/aktualizacji pakietu.

Jeśli to jest cokolwiek innego (nie licząc wyżej wymienionych oraz pakietów z AUR, Snap i Flatpak) to nie polecam instalacji, a jedynie uruchamianie z poziomu zwykłego użytkownika – na wszelki wypadek, żeby przypadkiem niczego sobie nie zepsuć w systemie. Możesz też poprosić kogoś, kto się na tym zna, aby napisał ci PKGBUILD.

Mam zooma do konferencji webowych i teraz on wymaga aktualizacji do 5.0. Sciągnąłem uaktualnienie tar.xz i gdzies tam jest w downloadach. Co teraz?

Pudełko to programik add/rem software.
NIe wiem jak się uruchamia Pacmana, może to ten sam program, ale nie pojawia się w nim uaktualnienie dla zooma, do zazanczenia opcji upgrade.
Zatem, jak?

Wpisałem w terminalu sudo pacman -Syyu - nothing to upgrade
A przeceiż ściagnąłem upgradea

No, trudno. Liczyłem na doświadczenie kolegów.

Na stronie producenta jest łopatologiczna instrukcja:

Warto się też zapoznać z elementarnymi podstawami do których linkowałem we wcześniejszym poście.
Jeśli to jest za trudne to nie wróżę sukcesów w użytkowaniu Linuksa.

Zoom jest też w AUR.

Zoom znajduje się w AUR, więc nie potrzebujesz ściągać do tego żadnych plików. Wystarczy, że w konsoli wpiszesz sudo pacman build zoom.

Jak instalujesz programy spoza repozytoriów to jest oczywiste, że manager pakietów powie ci, że nie ma nic do zrobienia. Zdecydowanie odradzam takie praktyki.

1lajk

jednak otrzymuję no operation specyfied (use -h for help)

Też tak uważam. Mam go dlatego, by nie mieć widowsa ,i ciągnie na słabszym pc.

Racja, moja pomyłka, powinno być sudo pamac build zoom :wink:

teraz - building packages as root is not allowed

Logicznym wydaje się spróbowanie z konta zwykłego użytkownika?
Czyli bez sudo.

1lajk

Ale co dalej, i czy to tak powinno wyglądać na tym etapie?

Wszystko jest ok, niepotrzebnie wybrałeś edytowanie PKGBUILD-a, wyjdź z edytora (crl+x) a instalacja powinna dalej pójść bez problemów o ile niczego w tym pliku nie wykasowałeś ani nie dopisałeś.

Powinno to wyglądać zupełnie inaczej…
Decydując się na używanie Linuksa należałoby w pierwszej kolejności przyswoić sobie chociażby elementarne informacje np. na temat instalowania oprogramowania w danej dystrybucji.

A z Zoom masz dwie opcje:

  1. Albo decydujesz się na instalowanie i uaktualnianie ręcznie programu ze strony producenta wg dostarczonej dokumentacji -> https://support.zoom.us/hc/en-us/articles/204206269-Installing-or-updating-Zoom-on-Linux#h_82c54ba8-497c-4a8e-a983-b3be702c11c9
    Skoro już i tak zainstalowałeś w ten sposób to w identyczny możesz zaktualizować - opisane jest to dokładnie.

  2. Albo korzystasz z AUR - wtedy trzeba co nieco na ten temat poczytać i zrozumieć.

Udało się, z terminala.
Dziękuję za pomoc. Miłego weekendu.

Nie majstrowałem pierwotnie zbyt daleko od opisu, ale te szczególiki…

13 posts were merged into an existing topic: Korzystanie z obcych repozytoriów

forum.manjaro.pl - polskie wsparcie Manjaro. Hostowane przez: vpsadmin - hosting Discourse