Usunięte Wsparcie Dla BIOS, Dziala Tylko UEFI

Manjaro (Live) od długiego czasu uruchamia się tylko na UEFi. Nie uruchamia się na BIOS-ie.
Czarny ekran, a w górnym lewym rogu napis “GRUB!”. Inne dystrybucje (Debian Live, Ubuntu, KaOS, MX, PC-LinuxOS, …) nie mają żadnych problemów z komputerem z BIOSem, tylko Manjaro.

Proszę poinformować deweloperów, ponieważ powyżdza sytuacja ma miejsce od bardzo długiego czasu i developerzy muszą wyedukować się w kwestii bootowania systemu.

Nic mi nie wiadomo, żeby Manjaro nie uruchamiało się na BIOS-ie, nikt nigdzie nie zgłaszał podobnych problemów w ostatnim czasie. Być może wynika to z twojej specyficznej konfiguracji sprzętowej lub nietypowych ustawień.

Błędy możesz samodzielnie zgłosić na oficjalnym forum Manjaro – jednak taka informacja jak tutaj nie wystarczy, obowiązkowo powinieneś też podać swoją konfigurację sprzętową, podać jak masz skonfigurowany BIOS i opisać, w jaki sposób odtworzyć ten błąd.

Trochę o podstawowych różnicach między BIOS a UEFI.

Nic podobnego. U mnie działa.
Zj… dla developer’ów przedwczesne.

Niestety nie macie racji, już ktoś tu to napisał:

Dlatego podjąłem ten wątek. Może ktoś znający temat bootowania (maskara nawiasem mówiąc), podejmie się debugowania i porównania z Ubuntu, Debianem czy KaOS (gość kurcze się zna na tym, ale wątpię żeby pomógł innej dystrybucji…, niestety nie używam, gdyż repo KaOS jest strasznie ograniczone i brakuje podstawowego oprogramowania, bez którega ani rusz… np. f2fs-utils czy gnome-disk-utility, nie wspominając o wielu innych…).

@jaroman tylko że tam nie ma ani słowa o BIOS-ie, więc nie wiem skąd ten wniosek.

Ogólnie rzecz biorąc nie powinno mieć znaczenia, czy uruchamiamy z BIOS, czy z UEFI, powinno działać. Gdyby było inaczej deweloperzy by nas o tym uprzedzili. Jeśli faktycznie masz z tym problem, to powinieneś zgłosić to ze wszystkimi danym deweloperom na głównym forum, tak żeby ktoś inny mógł odtworzyć sytuację i potwierdzić problem.

Jednostkowy przypadek nie upoważnia do generalizowania. Uważam się za człowieka inteligentnego (średnio, ale jednak inteligentnego). To nie jest jednak powód do tego, aby wszystkich ludzi traktować, jakby byli po lekturze instrukcji używania moozgu (to nie przytyk, broń Boże. Tylko dowcipny, mam nadzieję, przykład). Dlatego @jaroman, nie wiń dystrybucji za, to że nie działa w trybie BIOS, skoro działa. Skąd ta pewność płynąca z mojej klawiatury? Bo wszystkie kilkanaście instalacji, których dotykam częściej lub rzadziej, nie widziały nigdy (i widzieć nie będą) na oczy UEFI.

Zaczął bym, w Twoim przypadku, od konfiguracji BIOS/UEFI.

forum.manjaro.pl - polskie wsparcie Manjaro. Hostowane przez: vpsadmin - hosting Discourse