[Stable Update] 2020-12-30 - Kernels, KDE, Cinnamon, LibreOffice, Python 3.9, Mesa 20.3.1

Ostatnia w tym roku duża aktualizacja gałęzi stable.

U mnie na Openboxie/Maboxie poszło z malutkimi problemami.

Emulator terminala - Terminator - w repo Manjaro jest skopany i nie odpala się (wersja 1.92-3).
Sprawę załatwiła budowa paczki z nowszą wersją 2.0.1 - wrzucona de repo dla Maboxiarzy :slight_smile:

Ważna informacja dla posiadaczy kart Nvidia i własnościowych sterowników. W związku z porzuceniem wsparcia dla starszych sterowników i zmianą nazewnictwa możecie się natknąć na problem podobny do tego (w zależności od tego jakie sterowniki mieliście zainstalowane):

nvidia-utils and nvidia-455xx-utils are in conflict

Może się on pojawić przy próbie instalacji nowego kernela lub sterowników w MHWD. Należy usunąć stary pakiet za pomocą pacmana/pamaca (w wymienionym przypadku jest to nvidia-455xx-utils) oraz zainstalować właściwe sterowniki przez MHWD, a więc dla powyższego przykładu w konsoli:

sudo pacman -R nvidia-455xx-utils
sudo mhwd -a pci nonfree 0300

Oczywiście, jeśli wcześniej mieliście w systemie inne sterowniki, to odpowiednio dostosowujecie pierwsze polecenie.

Póki co, jedna maszyna zaktualizowana (Budgie). Update usunął stare pakiety nVidii i zainstalował nowy. Żadnych widocznych problemów w trakcie aktualizacji i po restarcie.

Po aktualizacji dziś. konfliktujące zależności:

  • catfish i zeitgeist są w konflikcie
    Co należy zrobić aby ten problem rozwiązać?

@Marekl21, odinstalowałbym którykolwiek pakiet (ten, który nie pociągnie za sobą długiej listy innych paczek), wykonał update systemu i zainstalował pakiet ponownie. Tak bym zrobił. Rozumiem, że aktualizacja nie poszła.

Witam. Dzięki za radę. Tak zrobię. Aktualizacja poszła bo wstrzymałem aktualizację catfish. Pozdrawiam. Dobrego Nowego Roku.

Na Dellu 7450 z dGPU Nvidii (840M, 2GBVRAM) XFCE bez problemu. Prócz Catfish i Zeitgeist. Ale to drobiazg.
Natomiast na 6400 z NVS 160M system nie wstaje w trybie graficznym. Powodem jet najprawdoodobniej nVidia 940xx, która została porzucona. Będę jeszcze walczył.

  1. Konflikt: catfish / zeitgeist
    Początkowo sądziłem (po zgłoszeniu @Marekl21), że to jakaś specyficzna sytuacja, ale wygląda na to, że jednak prawidłowość. Z jakiegoś powodu (przemyślanego lub błędu) oba pakiety, są w konflikcie i nie można ich jednocześnie zainstalować. Nie przeszukiwałem jeszcze, w tej sprawie i kolejnej, oficjalnego forum.

  2. Konflikt: grub / grub-customizer
    Nie zdążyłem się jeszcze przyjrzeć tematowi, ale ten konflikt wydaje się być bardziej racjonalny - choć, póki co, nie wykluczam jakiejś pomyłki.

  3. sudo w pamac (CLI)
    Zmiana przyszła wcześniej, z małymi update’ami Pamac’a, ale chyba o nich nie wspominaliśmy, a jest istotna. Pamac nie używa już własnego mechanizmu kontroli użycia sudo (chwilowo, na stałe?), tylko:

  • uruchamiamy go poprzez terminalowe sudo (pojawiają się wtedy dziwne komunikaty błędów);
  • uruchamiamy ‘normalnie’, a gdy ten potrzebuje uprawnień, to woła domyślne graficzne ‘sudo’.

Ad 2. " grub-customizer is not supported by Manjaro. If you want to use it, you’re on your own. You may use grub-vanilla instead if you insist on using it. Howver, if it breaks something, you will not receive any support here." link.

Czyli ostateczny rozwód z grub-customizer. Czasem był przydatny, ale płakać nie będę.

U mnie po aktualizacji nie wstaje system. Nawet nie chce mi się drążyć tematu. Obstawiam konflikt z GeForcem. Timeshift poszedł w ruch i tyle :confused:
Manjaro KDE, Kernel 5.4, Nvidia NVS3100 (Geforce 210M)

EDIT: Spróbuję rady użytkownika Tomek, mam nadzieję, że pomoże :wink:

Odradzam, ta karta nie działa ze sterownikami 455xx, a tylko takich kart dotyczy moje rozwiązanie. Zresztą problemu nie powinno już być, deweloperzy wydali odpowiednie poprawki.

Jest to celowe ale chwilowe - choć sytuacja ma miejsce od lutego 2020.

Manjaro usunęło sterownik nvidi 418, bo rzekomo stare sterowniki przestały być wspierane. Dlaczego zatem zostawiono sterowniki w wersji 390 ? Mam 4-letniego lapka i właśnie zostałem zmuszony do przesiadki na sterowniki 455, które są gorsze od poprzednio używanych w wersji 418. Dobrze że w ogóle działają.

Dokładnie tylko dla szukających podam źródło .

Dzięki, spróbuję tego

Moja karta też nie jest niby wspierana, ale działa na sterach 455. Różnica tylko że na starych sterownikach 418 działała wydajniej. Co śmieszniejsze, na sterownikach 390 które oficjalnie wspierają moją kartę nie działają mi 32bitowe gierki pod wine, na 455 działają. To jakaś paranoja

Ja akurat mam odmienne doświadczenia. Długo siedziałem na sterownikach 430, ale w pewnym momencie coś się zaczęło psuć i po przesiadce na 450 (a potem na 455) wszystko zaczęło chodzić wyraźnie lepiej. Każdy sprzęt jest inny, nie da się przewidzieć wszystkiego.

Masz jeszcze możliwość samodzielnej kompilacji starszych sterowników, ale:

  • nie wiadomo jak długo będzie to możliwe,
  • mogą wystąpić różne nieprzewidziane problemy,
  • będziesz musiał wykonywać te zaklęcia przy każdej aktualizacji kernela.

catfish wykorzystuje informacje z zeitgeist do poszukiwania plików i na nim wykłada się - to wyjaśnia oznaczenie konfliktu pomiędzy pakietami. Oznaczenie zapewne zniknie, po poprawce - trudno jednak powiedzieć kiedy i po czyjej stronie leży problem (ze zgłoszenia błędu nie można wyciągnąć takiej informacji).

forum.manjaro.pl - polskie wsparcie Manjaro. Hostowane przez: vpsadmin - hosting Discourse