Problem z WiFi na extensa 5200

Witam.
Po wgraniu systemu Manjaro XFCE nie wykrywa mi sieci WiFi. Skorzystałem z tego poradnika

### Dla Arch Linux, Bridge Linux

Logujemy się jako root:

su root

Następnie podajemy hasło.

Instalujemy firmware:

pacman -S b43-firmware
Lub
pacman -S b43-firmware-legacy

Ładujemy moduł b43:

modprobe b43

Od teraz powinno zacząć działać połączenie Wifi, ale aby dodać do automatycznego startu musimy jeszcze wpisać:

echo "b43" >> /etc/modules

Niestety po każdym odpaleniu kompa muszę wklepywać modprobe b43 i wtedy mam neta. Jak zrobić aby to działało bez tej czynności?

Skąd ten poradnik?
Aby moduł był ładowany automatycznie podczas startu systemu, należy go dopisać do pliku /etc/modules-load.d/modules.conf

Na przykład poleceniem z konta root:

sudo su -
echo b43 >> /etc/modules-load.d/modules.conf

Stąd

Niestety nadal nie działa.

Manjaro ma swoje narzędzia do zarządzania sterownikami (MHWD) – zajrzałeś tam w ogóle i odinstalowałeś poprzednie sterowniki? Pierwszym miejscem gdzie powinieneś szukać rozwiązania powinno być forum lub wiki Manjaro. Tu przykładowo twój problem – zakładając oczywiście, że karta WiFi jest w twoim laptopie taka sama jak w linku, który podałeś.

Polecam przyswoić sobie Co musisz wiedzieć, aby bezsteresowo używać Manjaro?

Dorzucę tylko jeszcze to.

Edit.
Pokaż wynik:

cat /etc/modules-load.d/modules.conf

Porada jest z 2014 roku - Arch używał już wtedy systemd? Nie jestem pewien.
@Redzik, zasada ‘Google twoim najlepszym przyjacielem’, nie musi być prawdziwa. Jeżeli masz problemy z systemem, to pytaj innych kumpli:
https://forum.manjaro.org
https://forum.manjaro.pl
https://wiki.archlinux.org
Zainwestuj czas w poznanie zasad rządzących Manjaro (i innych dystrybucji Arch-like) i trzymaj się tego.

> # List of modules to load at boot
> b43 b43
> b43

Teraz to za dużo tam jest. Usun, zostaw jedno b43
Spróbuj wykonać to co jest w moim linku.

sudo su 
touch /etc/modprobe.d/b43.conf
echo options b43 allhwsupport=1 >> /etc/modprobe.d/b43.conf

Jesli nie zadziała to po restarcie zobacz jaki sterownik się ładuje, przed załadowaniem ręcznie b43, np:

inxi -ixx

Może trzeba będzie dać coś do czarnej listy.

Jak to usunąć? bo przez edytor nie mam uprawnień a nie będę szukał 3 dni jak korzystać z konsoli już wolę wpisywać to modprobe po każdym odpaleniu kompa. Ewentualnie gdy (jak) znajdę czas i dojdę do tego jak to usunąć to napiszę, że to wykonałem Ale kiedy to nie jestem wstanie napisać

sudo nano /etc/modprobe.d/b43.conf

Za nano możesz podstawić dowolny edytor.

Nie pomogło

inxi -ixx
Network:
  Device-1: Broadcom and subsidiaries NetLink BCM5787M Gigabit Ethernet PCI 
  Express 
  vendor: Acer Incorporated ALI driver: tg3 v: 3.137 port: 1c20 
  bus ID: 02:00.0 chip ID: 14e4:1693 
  Device-2: Broadcom and subsidiaries BCM4311 802.11b/g WLAN 
  vendor: AMBIT Microsystem driver: N/A port: 1c20 bus ID: 04:00.0 
  chip ID: 14e4:4311 
  WAN IP: No WAN IP data found. Connected to the web? SSL issues? 

@Tomek Dzięki. Zaoszczędziłeś mi 3 dni szukania :smiley: Przyda się na przyszłość.

To mam rozumieć, że stworzyłeś plik b43.conf?
Pokaż:

ls /etc/modprobe.d
cat /etc/modprobe.d/b43.conf

Do łatwej edycji plików możesz doinstalować mc (midnight commander)

Czy i jak instalowałeś

Bo te pakiety są w AUR.
Pokaż:

pacman -Qs b43

I tak na koniec, podaj jeszcze wynik:

lspci -knn | grep Net -A3; rfkill list

Do przeczytania i jeszcze to.

@Redzik
Dostałeś do przerobienia, od @aquila, link:
https://www.dedoimedo.com/computers/manjaro-broadcom-wireless.html
(jak i bezpośrednio parę konkretnych porad). Z Twoich wpisów nie wynika, czy czytałeś, czy cokolwiek z tego robiłeś. Nie bardzo wiadomo, czy zrobiłeś, to co tam zalecają, ale nie działa, czy może zrobiłeś coś tylko, albo nic. Dlatego wyjaśnijmy, w paru żołnierskich zdaniach, najważniejsze elementy:

  1. Sprawdzenie, czy karta nie jest wyłączona (fizycznym przełącznikiem lub software’owo):
$ rfkill list

Jeżeli działa, to przechodzisz do dwóch kolejnych punktów.

  1. Dodanie do pliku /etc/modules-load.d/modules.conf wpisu b43:
/etc/modules-load.d/modules.conf
--------------------------------------------
# List of modules to load at boot
b43
  1. Stworzenie pliku /etc/modprobe.d z odpowiednią zawartością:
/etc/modprobe.d
--------------------------------------------
options b43 allhwsupport=1

Oczywiście, restart systemu po dokonanych modyfikacjach.
Z komend, które mogą być przydatne przy analizie takich przypadków, dodałbym jeszcze:

$ mhwd -lh -d

Uzyskasz długą listę pozycji, z których jedna dotyczy karty Wi-Fi, ze szczegółowymi informacjami na jej temat.

ls /etc/modprobe.d
b43.conf  b43.conf.save  linux54-broadcom-wl.conf

cat /etc/modprobe.d/b43.conf
options b43 allhwsupport=1
options b43 allhwsupport=1

Wiem usunąć jeden.

Instalowałem wklepując pacman -S b43-firmware-legacy

pacman -Qs b43
local/b43-fwcutter 019-3
    firmware extractor for the b43 kernel module
local/manjaro-firmware 20160419-1
    Extra firmwares for Manjaro Linux

l    spci -knn | grep Net -A3; rfkill list
    02:00.0 Ethernet controller [0200]: Broadcom Inc. and subsidiaries NetLink BCM5787M Gigabit Ethernet PCI Express [14e4:1693] (rev 02)
    	Subsystem: Acer Incorporated [ALI] NetLink BCM5787M Gigabit Ethernet PCI Express [1025:011c]
    	Kernel driver in use: tg3
    	Kernel modules: tg3
    04:00.0 Network controller [0280]: Broadcom Inc. and subsidiaries BCM4311 802.11b/g WLAN [14e4:4311] (rev 01)
    	Subsystem: AMBIT Microsystem Corp. BCM4311 802.11b/g WLAN [1468:0422]
    	Kernel driver in use: b43-pci-bridge
    	Kernel modules: ssb, wl
    0: acer-wireless: Wireless LAN
    	Soft blocked: no
    	Hard blocked: no
    1: phy0: Wireless LAN
    	Soft blocked: no
    	Hard blocked: no

No to drugi link w moim poprzednim poście idealnie pasuje do Twojego problemu. Zrób po kolei wszystko co gość tam pisze, zwłaszcza o

b43-pci-bridge

forum.manjaro.pl - polskie wsparcie Manjaro. Hostowane przez: