Problem z Manjaro32 na EeePC


#1

Wątek wyodrębniony z innego.


Witam,
też mam EeePC z 2GB RAMu, ale po którejś aktualizacji padła grafika i przestał się uruchamiać. Przeinstalowałem system i zaktualizowałem wszystko poza Xorg i nawet chwile działało, ale po kolejnej padło wifi (chyba networkmanager coś psuje) i nie działa karta sieciowa. Po kilku próbach poddałem się, ale jeśli jest jakiś sposób na te bolączki to chętnie bym jeszcze go wskrzesił. Może kolega podpowie co można zrobić, aby ruszył.


W ramach rozrywki
#2

Rozumiem, że pisząc ‘padła grafika’ masz na myśli pad software’u, a nie hardware’u. Można by szczegółowo analizować poszczególne problemy, ale ja - w tej sytuacji - zacząłbym od ogółu, od sprawdzenia, czy sprzęt jest sprawny:

  • trzymaj zasilanie na kablu;
  • sprawdź temperatury (maszyna ma swoje lata i może być zarośnięta filcem, a pasta na procesorze twarda jak skała);
  • wygrzej go (uruchom system z pen’a i popracuj na nim, tyle ile się da. Skonfiguruj go; zaktualizuj; daj mu popalić odtwarzając film w HD, z wewnętrznego dysku; ściągnij kilka ISO z systemami z net’u. Jak już Ci się znudzi, to uśpij go, a następnego dnia ciąg dalszy. Obserwuj zachowanie, słuchaj wentylatora i dysku, kontroluj obłożenie procesora);
  • sprawdź dysk (jest sporo narzędzi windows’owych; linux’owe dystrybucje live; albo komendą, która sprawdzi Ci, w tym przypadku, pierwszą partycję na dysku, sformatowaną pod ext4, automatycznie naprawiając błędy:
$ sudo fsck.ext4 -cfp /dev/sda1
  • dobrze by było również, w ramach sprawdzania dysku, zobaczyć co S.M.A.R.T. ma do powiedzenia na jego temat (jeżeli obsługuje tą technologię i jest włączony).

#3

Sprzęt działa jak należy na Manjaro 32bit do aktualizacji ( na innych dystrybucjach też działa prawidłowo, ale ja chciałem Manjaro). Po aktualizacji już się nie uruchamia. Myślałem, że może mając taki sam znasz problem i jego ewentualne rozwiązanie, ale albo ciebie nie dotyczy bo po aktualizacji działa prawidłowo, albo ja się źle wyraziłem w poprzednim poście i nie zostałem dobrze zrozumiany. Po aktualizacji sterowników grafiki przestaje się uruchamiać, a dodatkowo po którejś aktualizacji sterowników karty sieciowej nie ma też wifi. Jeśli problem jest znany i jest rozwiązanie to chętnie wypróbuje, jeśli nie to sobie podaruje i spiszę go na straty.
pozdrawiam


#4

Było ostatnio spor zawirowań z wersjami systemd. Może instalka Manjaro32 ma nowszą wersje, ale bez potrzebnych bibliotekm wtedy normalne, że się wysypała po aktualizacji standardowej.

Zainstaluj jeszcze raz i wykonaj aktualizację za pomocą:

sudo pacman -Syyuu

Tak, mają być dwa u w tym wypadku.

Albo jak nie chcesz instalować ponownie to uruchom wersję Manjaro32 live, otwórz terminal i:

sudo manjaro-chroot -a 
pacman -Syyuu
exit

#5

W takim razie, @Wiini, sytuacja wygląda inaczej, wyjaśniło się co nieco, więc:

  • również miałem podobny problem, choć manifestował się ciut odmiennie, ale zdarzyło się, to po updgrade’zie i skutkowało niemożnością uruchomienia systemu;
  • pomógł chroot, czyli dokładnie, to co radzi @michaldybczak w poprzednim poście. Z tą różnicą (różnicami dwiema), że nie stosowałem podwójnego ‘u’ (pacman -Syyu - ponieważ miałem właściwą wersję systemd) i zamiast parametru ‘-a’ w chroot’cie musiałem podać lokalizację, bo automat miał problem ze znalezieniem instalacji (zapewne dlatego, że partycja była szyfrowana).

Możemy roboczo przyjąć, że praktyka pójdzie zgodnie z teorią, więc:

  1. Uruchamiasz system z pen’a. Przy okazji, masz świeżą wersję?
  2. Wydajesz komendę:
$ sudo manjaro-chroot -a
  1. Następnie:
$ pacman -Syyuu
  1. Po aktualizacji wychodzisz z chroot’a:
$ exit
  1. Zamykasz system, uruchamiasz z dysku, cieszysz się sprawną instalacją. Jeżeli coś pójdzie nie tak - pisz.

#6

Dziękuję za porady, dzisiaj powalczę i zobaczymy co z tego wyjdzie. Wynikami oczywiście się podzielę.
System świeży.
Pozdrawiam

Pięknie dziękuję, wszystko śmiga aż miło.

Pozdrawiam