Jeden użytkownik już się nie zaloguje

Sprawa nie jest specjalnie pilna… kolega, który prosił mnie o pomoc już sobie poradził… wolał kupić Windows :frowning:

Wyglądało to tak, że po wylogowaniu, a także po ponownym uruchomieniu systemu, przy jego nazwie nie pojawiało się w ogóle okienko na hasło. Po prostu nie mógł się zalogować i już!
Do tego zaszyfrował dysk i nie dało się wyciągnąć danych, uruchamiając komputer z USB

Dwa problemy w jednym temacie. Powiedzmy jednak, że tym razem zastosujemy humanistyczną teorię wyjątku, która mówi, że tenże potwierdza regułę i potraktujemy dwa kłopoty, jako dwa podpunkty jednego:

  1. Problemy z zalogowaniem:
    • jaki system?
    • jakie środowisko graficzne?
    • w którym momencie pojawił się błąd (aktualizacja, instalacja oprogramowania, modyfikacja konfiguracji, …)?
    • co znaczy ‘przy jego nazwie’, nazwie czego, mówimy o ekranie logowania?
  2. Problemy z szyfrowaniem:
    • co znaczy ‘nie dało się wyciągnąć danych’, jakie czynności zostały podjęte, czy były komunikaty błędów?
    • w jaki sposób dysk został zaszyfrowany, jakim oprogramowaniem?
    • kiedy dysk został zaszyfrowany, w trakcie instalacji systemu czy później?
    • mówimy o szyfrowaniu całodyskowym czy tylko niektórych partycji?

Ponieważ sprawa jest - z praktycznego punktu widzenia - nieaktualna, instalacja zapewne już nie istnieje i trudno będzie ustalić fakty i zweryfikować teorie, to najprawdopodobniej wątek ten będzie bardziej ćwiczeniem intelektualnym, niż poszukiwaniem realnego rozwiązania.

  1. Problem z zalogowaniem na przykładzie innego komputera
  • System Manjaro Linux.
  • Środowisko graficzne XFCE.
  • Błąd istnieje od początku, czyli od zainstalowania systemu.
  • Poniższy obrazek pokazuje stan na dzień dobry
    https://i.imgur.com/uKutYfW.jpg
    Kolejny obrazek pokazuje stan po wylogowaniu lub wyłączeniu, ponownym uruchomieniu itp. z danego konta (tu: Michał)
    https://i.imgur.com/mjIq44e.png
    To właśnie mniej więcej znaczy przy nazwie. Przy nazwie na ekranie logowania. Dodam, że tym razem się połapałem, że wina tkwi głównie po stronie “odrysowania” ekranu startowego, bo gdy kursor przybiera kształt jak na zdjęciu, można wpisać hasło, choć wpisuje się je na ślepo, a zalogowanie jest możliwe.
    Podobnie, po kliknięciu nazwy innego użytkownika, wadliwe okienko “się naprawia”. Tyle że tym razem siedziałem przed ekranem osobiście.
    Tym niemniej jest to wyjątkowo wkurzający błąd. Zwłaszcza gdy jest tylko jeden użytkownik
  1. Co do szyfrowania, to o ile zrozumiałem – rozmowa telefoniczna z bardzo zdenerwowanym Zwykłym (a nawet początkującym) Użytkownikiem – dysk został zaszyfrowany w trakcie instalacji. To, że dysk jest zaszyfrowany, dowiedziałem się, gdy na moją prośbę uruchomił komputer z pendrive, z którego zainstalował system…
    Wpadłem jeszcze na pomysł, żeby uruchomił komputer normalnie, a potem np. Ctrl+Alt+F5, logowanie, podłączenie USB i ręczne przekopiowanie danych. Ręczne, bo, jak wiemy, Midnight Commander nie jest standardowo instalowany, co osobiście uważam za krańcowy idiotyzm.
    Na wieść o pracy w trybie tekstowym połączenie zostało przerwane. Dużo później dowiedziałem się, że kolega wezwał pogotowie komputerowe, a tamci przywrócili go do jedynie słusznego pionu.

ad.1
Obrazków brak. Może za duże, może coś poszło nie tak. Spróbuj raz jeszcze. Wygląda, to na problem z odświeżaniem ekranu lub generalnie z rysowaniem okna z user’em i hasłem - zaobserwowałem coś takiego na niektórych swoich instalacjach.

ad.2
Dysk został zaszyfrowany w trakcie instalacji, bo instalator otrzymał takie polecenie, w postaci zaznaczonej opcji. Nie stanowi, to jednak problemu, bo można taki dysk odczytać pod inną instancją systemu, również uruchomionego z pen’a/DVD.
Jeżeli mamy problem z zalogowaniem poprzez graficzny ekran logowania, to można przejść na inną konsolę (np. Ctrl+Alt+F5), zalogować się w trybie text’owym i:

$ startx

No i już mamy środowisko graficzne.
Dobrze, że go przywrócili. Istnieją, moim zdaniem, dwie sensowne ścieżki migracji na Linux’a:

  • ktoś instaluje mi system, konfiguruje pod moje gusta i potrzeby, wprowadza w podstawy, zapewnia wsparcie;
  • sam zmagam się z tematem, stopniowo zdobywając wiedzę i wykazując się cierpliwością oraz samozaparciem.

Skoro user odpadł, nie walczył, to dobrze się stało, że wrócił do ‘jedynie słusznego pionu’. Jak chcesz zmienić system, to powód sam się znajdzie.


EDIT-20191022-1555 … już widzę obrazki … Skoro, to jest Xfce, to zapewne i LightDM, ale nie wygląda mi, to na LightDM. Nie wiem. Może problem z odświeżaniem zawartości ekranu (sterowniki), może problem ze strony LightDM, albo nie zaktualizowany system. Nie przypominam sobie, abym coś takiego widział. Może ktoś będzie miał jakiś pomysł.


EDIT-20191022-1656@Ksen, ponieważ jest jakiś problem z widocznością obrazków w Twoim poście, zamieniłem osadzenie na zwykłe link’i.


EDIT-20191022-1700 … a może problem z widocznością pola z hasłem, podczas logowania, to problem ze stylem?

1lajk

3 posts were split to a new topic: Problem z osadzaniem obrazków w post’ach

To jest LightDM
Zainstalowane:
lightdm 1:1.30.0-2
lightdm-gtk-greeter 1:2.0.6-1
Ustawienia LightDM GTK+ Greeter (lightdm-gtk-greeter-settings) 1.2.2-3
lightdm-settings 1.2.8-1
lightdm-slick-greeter 1.2.7-1
light-locker 1.8.0-2

System “jest w pełni zaktualizowany”

jeszcze zrzut całego ekranu:


(tym razem upload)

EDIT:
Po uruchomieniu lightdm-gtk-greeter-settings wszystko ładnie działa, ale pozostaje bez wpływu na cokolwiek.
Natomiast w lightdm-settings (które zostało doinstalowane później) można konfigurować bez oporów i zmiany wpływają na widok.

Widzę, że motyw niefabryczny, albo modyfikowany. A co będzie po zmianie motywu LightDM?

lightdm-gtk-greeter-settings-pkexec - po dokonaniu zmian trzeba wykonać restart (systemu lub LightDM) albo użyć przycisku ‘Wczytaj ponownie’.

OK
No to jeszcze raz:
Uruchamiam lightdm-gtk-greeter-settings-pkexec
Karty ustawień wyglądają tak:





Pokazane na pierwszej karcie tło to wypieszczony obrazek z łopatologiczną instrukcją dla głównego użytkownika:

…którym jest starszy pan na emeryturze [1]

Teraz zmieniam położenie okna


Zapisuję

Uruchamiam ponownie system
…i nic się nie zmienia!

Z kolei uruchamiam pkexec lightdm-settings
Karty ustawień wyglądają tak:




Tło wskazane na pierwszej karcie to obrazek
/usr/share/backgrounds/xfce/manjaro-dog.jpg
przerobiony tak, żeby pasował do rozmiarów wyświetlacza.

…i owszem, tutaj każda zmiana wywołuje odpowiedni efekt.

Nie mam zielonego pojęcia, dlaczego tak się dzieje. :frowning:
Oczywiście wolałbym, aby tłem był ów instruktażowy obrazek oraz pojedynczy panel, w którym użytkowników wybierałoby się z listy rozwijanej. Jednak nie mam pojęcia, jak to otrzymać.


[1] Kopiowanie dozwolone :wink:

Możliwości obu programów, jak widzę, są lekko odmienne, choć główne funkcje występują w obu.

  1. Wskazują jednak na odmienne wartości dotyczące motywu. Który pokazuje prawidłowy?
  2. Skonfiguruj LightDM tym, który działa, a potem zasęp się nad problemem.
  3. Tapeta z instrukcją jest robiona dla panelu na dole, a na screen’ie widzę go na górze. Domyślnie panel jest na dole i nie można tego zmodyfikować z interface’u graficznego. Chyba, że coś ostatnio uległo zmianie.
  4. Proponuję zajrzeć i sprawdzić, czy nie ma jakiegoś bałaganu w konfiguracji:
/etc/lightdm/lightdm.conf
/etc/lightdm/lightdm-gtk-greeter.conf
/etc/lightdm/lightdm.conf.pacnew
/etc/lightdm/lightdm-gtk-greeter.conf.pacnew

/etc/lightdm/lightdm.conf

   run-directory=/run/lightdm

   [Seat:*]
   greeter-session=lightdm-slick-greeter
   user-session=xfce
   autologin-user=profesor

/etc/lightdm/lightdm-gtk-greeter.conf

    background = /home/Magazyn/art/Logowanie_p.png
    font-name = Ubuntu 17
    xft-antialias = true
    icon-theme-name = Human
    screensaver-timeout = 40
    theme-name = HighContrast
    cursor-theme-name = xcursor-breeze
    show-clock = false
    default-user-image = #avatar-default
    xft-hintstyle = hintfull
    position = 50%,end 50%,center
    clock-format = %R
    panel-position = bottom
    indicators = ~host;~spacer;~clock;~spacer;~power
    user-background = false
    a11y-states = +contrast;+font

/etc/lightdm/lightdm.conf.pacnew

    run-directory=/run/lightdm

    [Seat:*]
    session-wrapper=/etc/lightdm/Xsession

/etc/lightdm/lightdm-gtk-greeter.conf.pacnew
(w ogóle nie mam tego pliku)

Jeszcze dwa dodatkowe pliki, do których powyższe się odwołują:
/etc/lightdm/slick-greeter.conf

   background=/home/Magazyn/wallpapers/Abstrakcje/manjaro-dog.jpg
   icon-theme-name=Papirus-Adapta-Maia
   show-a11y=false
   show-power=false
   show-keyboard=false
   theme-name=Adapta-Maia

/etc/lightdm/Xsession

    #
    # LightDM wrapper to run around X sessions.

    echo "Running X session wrapper"

    # Load profile
    for file in "/etc/profile" "$HOME/.profile" "/etc/xprofile" "$HOME/.xprofile"; do
        if [ -f "$file" ]; then
            echo "Loading profile from $file";
            . "$file"
        fi
    done

    # Load resources
    for file in "/etc/X11/Xresources" "$HOME/.Xresources"; do
        if [ -f "$file" ]; then
            echo "Loading resource: $file"
            xrdb -merge "$file"
        fi
    done

    # Load keymaps
    for file in "/etc/X11/Xkbmap" "$HOME/.Xkbmap"; do
        if [ -f "$file" ]; then
            echo "Loading keymap: $file"
            setxkbmap `cat "$file"`
            XKB_IN_USE=yes
        fi
    done

    # Load xmodmap if not using XKB
    if [ -z "$XKB_IN_USE" ]; then
        for file in "/etc/X11/Xmodmap" "$HOME/.Xmodmap"; do
            if [ -f "$file" ]; then
               echo "Loading modmap: $file"
               xmodmap "$file"
            fi
        done
    fi

    unset XKB_IN_USE

    # Run all system xinitrc shell scripts
    xinitdir="/etc/X11/xinit/xinitrc.d"
    if [ -d "$xinitdir" ]; then
        for script in $xinitdir/*; do
            echo "Loading xinit script $script"
            if [ -x "$script" -a ! -d "$script" ]; then
                . "$script"
            fi
        done
    fi

    # Run user xsession shell script
    script="$HOME/.xsession"
    if [ -x "$script" -a ! -d "$script" ]; then
        echo "Loading xsession script $script"
        . "$script"
    fi

    echo "X session wrapper complete, running session $@"

    exec $@

PS:
Starałem się odpowiednio sformatować wpisy, ale wyglada to wciąż tak jak widać. Pozostaje dla mnie niezgłębioną tajemnicą, dlaczego p.t. administracja upiera się przy tym skrypcie forum. IMHO phpBB byłoby dużo lepsze:
Oto, Jak powyższy wpis mógłby wyglądać w naprawdę profesjonalnym forum:


(ale nie wygląda :frowning:

Poniżej – tak wygląda forum pomocy phpBB w smartfonie, jakby ktoś miał wątpliwości.

Tego luksusu jesteśmy pozbawieni…

@Ksen Wszystkim nie da się dogodzić…
Jak ci tak bardzo się nie podoba to forum to załóż swoje profesjonalne na phpBB , wtedy nie będziesz czuł się pozbawiony luksusów :wink:

/etc/lightdm/lightdm.conf

  • greeter-session=lightdm-slick-greeter
    slick-greeter - wydaje mi się (tak jeszcze niedawno było), że nie jest, to domyślny greeter do LightDM. A więc grzebanko było. Nie używasz gtk-greeter, tylko slick-greeter.
  • Czy przy autologowaniu, nie powinna być również odkomentowana linia:
    pam-autologin-service=lightdm-autologin
  • session-wrapper=/etc/lightdm/Xsession - wydaje mi się, że wiersz powinien być odkomentowany.

/etc/lightdm/lightdm-gtk-greeter.conf

  • Nie używasz gtk-greeter, więc nawet nie spojrzałem.

/etc/*.pacnew

  • Referencyjne pliki z konfiguracją.

Jeżeli używasz slick-greeter, to dlaczego próbujesz konfigurować gtk-greeter ?


OT - nie wiem co masz do formatowania. U mnie działa bez zarzutu i wygląda jak trzeba, profesjonalnie.

U mnie też teraz wygląda poprawnie. Choć przysiągłbym, że kilkadziesiąt minut temu było tragicznie.
Nic nie rozumiem…

Prawdę mówią, w ogóle nie wiedziałem jak to się nazywa.
Używane były dwie aplikacje graficzne, które nazywają się “Okno logowania” i “Ustawienia LightDM GTK+ Greeter”
Bezpośrednio w plikach nic ręcznie nie zmieniałem.

No właśnie ‘GTK+ Greeter’, nie ‘Slick Greeter’.


Edytuj ostatniego post’a, nie pisz jednego pod drugim.

Jak usunę slick-greeter to wszystko wróci do normy?

A greeter is a GUI that prompts the user for credentials, lets the user select a session, and so on. It is possible to use LightDM without a greeter, but only if an automatic login is configured.
Pakiet lightdm-settings wymaga lightdm-slick-greeter . Greeter to poprostu wygląd ekranu logowania.
https://wiki.manjaro.org/index.php/Install_Display_Managers#Installing_LightDM

Nie wiem. Sprawdź. Nie czepiam się slick-greeter, nic do niego nie mam. Chodzi mi o to, że aktywny jest slick-greeter, więc jego musisz konfigurować, jeżeli chcesz zmienić wygląd ekranu logowania, a nie gtk-greeter.


lightdm-settings wymaga lightdm-slick-greeter, ale LightDM nie wymaga lightdm-settings.