Jak zmienić dni w Kalendarzu?

Ten kalendarz co się rozwija z góry jest całkiem fajny, ale denerwuje mnie fakt że zamiast pokazywać datę od poniedziałku do niedzieli, on pokazuje od niedzieli do soboty :confused:
Czy da się go jakoś zmienić, żeby pokazywał dni we właściwy sposób pn-nd, nie wiem gdzie się pokazuje nd-sb, ale chyba nie w polsce? xD
btw używam środowiska graficznego gnome

W kulturach opartych na Judaiżmie sobota jest ostatnim dniem tygodnia. Gdzieś w konfiguracji środowiska graficznego lub samego kalendarza musisz mieć ustawienia na ten temat.

Możesz również zajrzeć do:

$ manjaro-settings-manager

Ustawienia lokalne / Ustawienia szczegółowe

Sprawdź co tam masz, czy jest
Polski - Polska (pl_PL.UTF-8)


EDIT-20190805-2157 … poniżej, @Baks pyta o to samo, ale w wersji terminalowej.


Jeżeli potrzebujesz bardziej szczegółowych informacji, to czekaj na kogoś, kto używa GNOME.

Używam Gnome i nic nie musiałem ustawiać aby kalendarz wyglądał tak:
kalendarz_sc
podaj wynik polecenia w terminalu : locale
u mnie jest taki:

LANG=pl_PL.UTF-8
LC_CTYPE=
LC_NUMERIC=pl_PL.UTF-8
LC_TIME=pl_PL.UTF-8
LC_COLLATE="pl_PL.UTF-8"
LC_MONETARY=pl_PL.UTF-8
LC_MESSAGES="pl_PL.UTF-8"
LC_PAPER=pl_PL.UTF-8
LC_NAME=pl_PL.UTF-8
LC_ADDRESS=pl_PL.UTF-8
LC_TELEPHONE=pl_PL.UTF-8
LC_MEASUREMENT=pl_PL.UTF-8
LC_IDENTIFICATION=pl_PL.UTF-8
LC_ALL=

Dodatkowy link : https://wiki.manjaro.org/index.php?title=Locale tam również piszą o :

Cytat
The locale is all the settings related to localization, like language, time, currency etc. In Manjaro you can set the desired locale settings with Manjaro Settings Manager GUI application.

Czyli @azja podał najlepsze rozwiązanie.

wszystko w locale mam ustawione na “en_US.UTF-8”
i ja też nic nie zmieniałem w ustawieniach gnome, jako default miałem nd-sb. ;-;

Pewnie podczas instalacji leciałeś po angielskich default’ach. Jeżeli nie potrzebujesz, z jakichś powodów, ustawień US, to zmień na PL, a US wywal.

Gdy już zmienisz z angielskiego na polski, wpisz w terminalu jako root
locale-gen

Moim zdaniem, wykonanie zmian z poziomu interface’u graficznego (wpis wyżej) jest tym samym, co:

  1. Modyfikacja pliku /etc/locale.gen
    (odkomentowanie odpowiednich języków);
  2. Wykonanie komendy sudo locale-gen
    (wygenerowanie /usr/lib/locale/locale-archive na bazie /etc/locale.gen);
  3. Wykonanie komendy sudo localectl set-locale LANG=pl_PL.UTF-8
    (wygenerowanie pliku /etc/locale.conf).

To tylko przypuszczenie graniczące z pewnością, więc zalecam weryfikację. Poza tym warto zwrócić uwagę na plik ~/.xprofile, w którym może być odmienna konfiguracja użytkownika, nadpisująca globalną (nie wiem jak, to się ma do wartości widocznych w interface’ie graficznym).

Proponuję jeszcze ustawić w /etc/vconsole.conf:

KEYMAP=pl2
FONT=Lat2-Terminus16
FONT_MAP=8859-2

aby mieć piękne polskie czcionki w terminalu (nie GUI).

Doprecyzuję tylko, bo dość często spotykam się z błędną interpretacją: @Baks nie pisze o emulatorze terminala (oknie text’owym w środowisku graficznym), tylko o czysto text’owej konsoli (tty2 … 6 / Ctrl+Alt+F2 … F6).

1lajk

offtop

łojej :scream: