Jak zainstalować 4KVideoDownloader

Witam serdecznie,
Pod Ubuntu i Mincie miałem zainstalowanego 4KVideoDownloader do pobierania filmów z Youtube. Ze strony producenta pobrać można właśnie tylko na tego Linuxa. @robson75 pisał o nim w swoim wpisie Problemy z Youtube i polecił że dobrze działający jest poprawiony przez pavbaranov -a obecnie dostępny w POLAUR
Ale tam jest tylko kod, który mi niewiele mówi i innym mniej zaawansowanym też.
Kod%20programu
Może ktoś znający się na tym wyjaśnił by tym mniej obeznanym - co i jak po kolei.

Ja używam ClipGrab, szybciej się instaluje bo 4k u mnie instalacja idzie długo więc jak przyjdzie aktualizacja to znowu jest masakra. Instalacja jednego czy drugiego z repo AUR. Jak jest włączone to ja z instalacją nigdy nie miałem problemów.

tworzysz sobie katalog np: 4KVideoDownloader gdzieś u siebie w /home/user

przechodzisz do tego katalogu i postępujesz zgodnie z instrukcją jaka jest na stronie
cała filozofia i po jakimś czasie masz gotową paczkę do instalacji…

i najbardziej powinien cię interesować PKGBUILD tamte pozostałe pliki to tylko dopełnienie PKGBULID

OK - ale gdzie jest ta instrukcja zgodnie z która należy postępować?

@lcoyote
Po pobraniu repa aur-rebased musisz go rozpakować, następnie wchodzisz do katalogu 4kvideodownloader-ffmpeg i w tym katalogu uruchamiasz terminal i wpisujesz makepkg -si, i w tym momencie zacznie się budowa.
Po zakończeniu budowy wyskoczy tobie info że paczki wcześniej zbudowane nie mogą zostać zainstalowane bo coś tam. Trzeba je zainstalować przy pomocy komendy sudo pacman -U nazwa_paczki .

Zassałem zgodnie z poleceniem

git clone https://github.com/polaur/aur-rebased.git

Zostało to wszystko zassane do mojego katalogu domowego i dalej to już tylko błędy, bo nie wiem co za polecenie wydać do instalacji. W katalogu sporo innych katalogów.


wydałem polecenie jak w instrukcji

cd /home/christophe/aur-rebased/package_name makepkg -srci
i nic.


Może ktoś “łapotologicznie” i dokładnie wyjaśni po kolejności. Byłbym wdzięczny nie tylko pewnikiem ja - ale inni też. Niby zwykła instalacja a w systemie jakieś trudności z instalacją. Chciałbym wiedzieć “dlaczego? jak? i po co?

Odpowiedz masz wyżej.

package_name

czyli na logikę to co chcesz zbudować w Twoim przypadku jest to 4kvideodownloader-ffmpeg

i potem

makepkg -srci

i dalej jak napisał @robson75 :wink:


tylko jak coś nie pójdzie jak powinno ( czyli nie będzie chciało się zbudować ) to mniej to na uwadze że
POLAUR jest dla Arch robiony ( pisze coby nie było problemów )

Nie udało się zainstalować (niespełnione zależności) -trudno.
Ale dzięki wszystkim @LinGruby @robson75 @warsztat-dom za pomoc w zajarzeniu instalacji w Manjaro. Pozdrawiam

no jak pisałem to dla Arch :wink:

a Manjaro ma swoją politykę pakietową i jest coraz dalej od Arch :wink:

@lcoyote
Jakie niespełnione zależności? Przecież ten PKGBUILD buduje 2 paczki tj. 4kvideodownloader oraz 4k-ffmpeg.
Po zbudowaniu w tym samym katalogu wydaj polecenie w terminalu
sudo pacman -U 4kvideodownloader-4.7.1.2712-1-x86_64.pkg.tar.xz 4k-ffmpeg-2.8-1-x86_64.pkg.tar.xz
I powinno się bez problemu zainstalować.

@robson75
w konsoli pojawił się komunikat

==> Instalowanie grupy pakietów 4kvideodownloader-ffmpeg za pomocą pacman -U...
wczytywanie pakietów…
błąd:  '/home/christophe/aur-rebased/4kvideodownloader-ffmpeg/4kvideodownloader-4.7.2.2732-1-x86_64.pkg.tar.xz': nie udało się znaleźć bądź odczytać pakietu
błąd:  '/home/christophe/aur-rebased/4kvideodownloader-ffmpeg/4k-ffmpeg-4.7.2.2732-1-x86_64.pkg.tar.xz': nie udało się znaleźć bądź odczytać pakietu
==> OSTRZEŻENIE: Nie udało się zainstalować zbudowanych pakietu(ów).
==> Sprzątanie...
==> Removing installed dependencies...
sprawdzanie zależności…

Pakiety (1) chrpath-0.16-2

Odzyskane miejsce na dysku:  0,06 MiB

:: Czy chcesz usunąć te pakiety? 

================
poszło wszystko OK - ostatnie pytanie wcisnąłem [n] i potem polecenie podane przez Ciebie

$ sudo pacman -U 4kvideodownloader-4.7.1.2712-1-x86_64.pkg.tar.xz 4k-ffmpeg-2.8-1-x86_64.pkg.tar.xz

Ale musisz uruchomić terminal w managerze plików w którym znajdują się te paczki.

Dla ułatwienia, wpisujesz 2 pierwsze litery nazwy paczki i wciskasz klawisz Tab.

Dżizas, Panowie! Cedzicie fragmentami informacji. Niby w jaki sposób @lcoyote ma się zorientować, jak należy, to zrobić prawidłowo, skoro wrzucacie mu na podwórko puzzle wyrwane z kontextu:

@lcoyote -> jeżeli chcesz się w to bawić, to najpierw poczytaj, bo brak wiedzy może Cię kosztować reinstalację systemu.

ale to są podstawy które każdy kto zaczyna budować swoje paczki powinien już wiedzieć…
a wszystko jest w sieci…


a swoją drogą teraz nikomu nie chce się szukać tylko coby gotowca dostać na tacy w taki sposób to nikt niczego się nigdy nie nauczy…
a Ci którzy podrzucają gotowce też im się w końcu znudzi xxx razy to samo…

Ten program jest dostępny także w AUR, ale z tego co widzę to wymaga do pracy starej wersji ffmpeg2.8.
Czy warto sobie, aż tak zaśmiecać system?
Może warto ogarnąć po prostu youtube-dl.

A jak komuś konsola straszna to można skorzystać z wtyczki do przeglądarki.

1lajk

Jeżeli uważasz, że to są podstawy, które pytający powinien znać i już (co jest dyskusyjne), to w ten sposób odpisz, zamiast dawać szczątkowe porady, które nie rozwiązują problemu, ani nie pomagają w jego zrozumieniu. Skieruj pytającego do źródła, w którym będzie w stanie zdobyć brakujące informacje.

Niektórzy urodzili się z moozgiem pełnym jedynie słusznej wiedzy, ale większość, aby ją zdobyć, musi poświęcić na to czas i ciężką pracę. Forum jest po to, aby pomóc w tej pracy - dawać rozwiązania i kierować do źródeł. Forum jest dla wszystkich, dla tych, którym wydaje się, że wiedzą wszystko i dla tych, którzy przekonani, są do tego, że nie mają pojęcia o niczym.


Przychylam się do tego zdania. Kiedyś korzystałem z wtyczki do przeglądarki, ale czynniki zewnętrzne pchnęły mnie na youtube-dl - ogarnąłem temat, stworzyłem kilka konfiguracji (w zależności od tego, co i w jaki sposób chcę zapisać) i teraz prosto, szybko i skutecznie zaspokaja wszelkie moje pragnienia … w zakresie download’u z YT.

Skoro mowa o youtube-dl to w AUR jest też wersja gui.


Ja korzystam z programu w konsoli. A problem z zapamiętaniem komend (bo nie ukrywajmy łatwe to nie jest) rozwiązałem tworząc aliasy w bashrc.

no i tu przechodzimy do sedna, tak mnie uczyli ponad 10 lat temu dawali nitkę i sam dochodziłem do kłębka, a teraz wszyscy chcą kłębek ( rozwiązanie podane na tacy ) a z tego co wiem po sobie to szukanie i czytanie nie boli a zostaje w pamięci…

fakt zajmuje to więcej czasu ale ( jak to mówią nauka nie idzie w las tylko w nas… )

a jak ktoś dostaje gotowca to klepie co mu podali ( działa ) i zapomina a jak sam trochę poświęci czasu to uwierz zostaje to w pamięci…