GRUB - rozdzielczość i responsywność

Gdy laptop się uruchamia, menu grub jest jak pokaz slajdów. Aktualizacja ekranu jest tak wolna, że po naciśnięciu klawiszy reagują po sekundzie lub dwóch. Rozdzielczość jest mała, pewnie 640x480. Ilość kolorów też niezbyt wielka. Ale z podglądem czegokolwiek trzeba poczekać aż wrócę do domu :wink:

Jeśli chodzi o słabą responsywność to gdy wyświetli ci się menu Grub wciśnij e przejdź do linii zaczynającej się od linux i dopisz na końcu nomodeset i zapisz zmiany (ctrl+x). Jeśli to nic nie zmienia (lub jest gorzej) to po restarcie wróci do starego, a jeśli jest lepiej to zrób na stałe wpis do /etc/default/grub. Zmień

GRUB_CMDLINE_LINUX_DEFAULT="quiet"

na

GRUB_CMDLINE_LINUX_DEFAULT="quiet nomodeset"

I zaktualizuj Grub

sudo update-grub

Co do rozdzielczości to gdy wyświetli ci się menu Grub wciśnij c i w konsoli wpisz videoinfo lub vbeinfo. Pokaże ci się lista dostępnych rozdzielczości. Najważniejsza jest ta którą podaje jako preferowaną, ale nic nie stoi na przeszkodzie aby mieć inną (z dostępnych). Wyjdź z konsoli (esc) i zaloguj się. Aby zmienić rozdzielczość znajdź w /etc/default/grub wpis

#GRUB_GFXMODE=auto

usuń # a po znaku równości wpisz swoją rozdzielczość (np. 1920x1080), a na koniec sudo update-grub

Zacznę od tego że zarówno videoinfo jak i vbeinfo zadziałały podobnie. Czyli ciemne tło i zero reakcji na klawiaturę.

Ręcznie wpisana rozdzielczość nic nie dała, natomiast teraz mam coś ciekawszego.

Na ekranie nic nie widać. Słyszę że dysk ostro pracuje ale trwa to już sporo czasu bez żadnych efektów

Bardzo to przypomina zepsutą grafikę (miałem kiedyś, nic przyjemnego). Aby się upewnić uruchom jakieś LiveCD. Spróbuj też podłączyć zewnętrzny monitor. Jak w obu przypadkach obraz będzie popsuty to pozostaje wymiana karty graficznej lub komputera, jeśli tylko w pierwszym to prawdopodobnie coś nie tak z ekranem. A jak będzie w porządku to wycofaj ostatnie zmiany wprowadzone do pliku /etc/default/grub, (pewnie to jest przyczyną) najlepiej z poziomu LiveCD jeśli masz problem z wyjściem z Grub-a.

logi i konfigi … wylaczyles w biosie uefi?

Zanim zalejemy forum rozwiązaniami, to @groot :

  1. Wrzuć zawartość /etc/default/grub
  2. Jeżeli modyfikowałeś zawartość powyższego pliku, to czy uaktualniłeś GRUB’a za pomocą
    sudo update-grub ?
  3. Co jeszcze modyfikowałeś (jakie pliki konfiguracyjne, jakie polecenia z poziomu systemu)?

Więc po kolei:
@Tomek
okazało się że grafika działa prawidłowo.

@ppp666
Nie ruszałem nic w BIOSie a tam jest ustawione Legacy

@azja

    GRUB_DEFAULT=saved
    GRUB_TIMEOUT=5
    GRUB_TIMEOUT_STYLE=menu
    GRUB_DISTRIBUTOR='Manjaro'
    GRUB_CMDLINE_LINUX_DEFAULT="quiet resume=UUID=da634635-7934-4c70-8796-3765d505475e"
    GRUB_CMDLINE_LINUX=""

    # If you want to enable the save default function, uncomment the following
    # line, and set GRUB_DEFAULT to saved.
    GRUB_SAVEDEFAULT=true

    # Preload both GPT and MBR modules so that they are not missed
    GRUB_PRELOAD_MODULES="part_gpt part_msdos"

    # Uncomment to enable booting from LUKS encrypted devices
    #GRUB_ENABLE_CRYPTODISK=y

    # Uncomment to use basic console
    GRUB_TERMINAL_INPUT=console

    # Uncomment to disable graphical terminal
    #GRUB_TERMINAL_OUTPUT=console

    # The resolution used on graphical terminal
    # note that you can use only modes which your graphic card supports via VBE
    # you can see them in real GRUB with the command 'videoinfo'
    GRUB_GFXMODE=auto

    # Uncomment to allow the kernel use the same resolution used by grub
    GRUB_GFXPAYLOAD_LINUX=keep

    # Uncomment if you want GRUB to pass to the Linux kernel the old parameter
    # format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"
    #GRUB_DISABLE_LINUX_UUID=true

    # Uncomment to disable generation of recovery mode menu entries
    GRUB_DISABLE_RECOVERY=true

    # Uncomment and set to the desired menu colors.  Used by normal and wallpaper
    # modes only.  Entries specified as foreground/background.
    GRUB_COLOR_NORMAL="light-gray/black"
    GRUB_COLOR_HIGHLIGHT="green/black"

    # Uncomment one of them for the gfx desired, a image background or a gfxtheme
    #GRUB_BACKGROUND="/usr/share/grub/background.png"
    GRUB_THEME="/usr/share/grub/themes/manjaro/theme.txt"

    # Uncomment to get a beep at GRUB start
    #GRUB_INIT_TUNE="480 440 1"

Oczywiście wszelkie zmiany updatowałem i nie dłubałem nigdzie indziej.

ten komp ci wstaje czy nie? masz dostep do dysku latwy? daj logi bo zeby jasnowidziec to musze 2 litry wypic ;d

W ustawieniach GRUB’a nie ma niczego szczególnego (mógłbyś jedynie GRUB_DISABLE_RECOVERY ustawić na false - ale, to nie na temat).

Jeżeli GRUB_GFXMODE=auto nie działa prawidłowo, to można:
GRUB_GFXMODE=800x600 albo 1024x768. Nie wiem jakie parametry ma Twój wyświetlacz, ale te rozdzielczości powinny być bezpieczne (nawet jeżeli masz szeroki monitor - co najwyżej proporcje będą zakłócone). Jak zadziała, to można ustawić bardziej natywną rozdzielczość.

Co do nomodeset - warto spróbować, ale nie miałem dotychczas takich problemów, ani nie używałem tego parametru, więc … nie mam zdania, ale jestem ciekaw.

Nie zmieniaj kilku elementów naraz - jedna zmiana, test, kolejna zmiana.

Jaką masz kartę graficzną?


EDIT-20190808-0214 … wcześniej działało, czy to świeża instalacja?

GPU: Mesa DRI Intel(R) Bay Trail

Ten config to backup przed zmianami, i śmiało można powiedzieć że jest to plik zaraz po instalowaniu systemu.
Zauważyłem pewną zależność, otóż jeśli używałem instalatora w wersji EFI to wszystko pięknie działa i nie ma się do czego przyczepić. Natomiast jeśli użyje się bootowania bez EFI to wygląda to nieładnie i działa ślamazarnie - właśnie tak jak to opisuję.

Sprawdź tak na wszelki wypadek czy w BIOS-ie jest wyłączony UEFI

  1. Nie jestem pewien: wrzuciłeś fabryczny plik /etc/default/grub, czy aktualny?
  2. Pytałem o kartę, bo pamiętam, że spotkałem się (w net’cie) z paroma problemami związanymi z Intelem - przejrzyj, przede wszystkim https://forum.manjaro.org/
    Poza tym, jeżeli masz intel’owską kartę i chcesz zastosować nomodeset, to równocześnie musisz użyć i915.modeset=0
    Żródło: https://wiki.archlinux.org/index.php/Kernel_mode_setting#Disabling_modesetting
  3. Temat UEFI pomijam, bo nie używam, nie wiem, nie znam.

EDIT-20190808-1428 … na temat kart Intel’a, konfiguracji i pułapek:
https://wiki.archlinux.org/index.php/Intel_graphics
Choć może być umiarkowanie pomocne, bo nie ma nic nt. GRUB’a.

Przywróciłem backup który zrobiłem zaraz po zainstalowaniu tak więc nie ma różnicy pomiędzy fabrycznym a aktualnym bo to jedno i to samo.

Co do samej karty dziękuję za podpowiedź. Zawsze to będzie lepiej działać :wink:

Możliwość wczesnego startu modułów do obsługi grafiki, można skonfigurować w mkinitcpio, w pliku /etc/mkinitcpio.conf (sekcja MODULES). Nie wiem jednak, czy ma to znaczenie na etapie GRUB’a, czy potem (Kernel modules to be loaded before any boot hooks are run). W każdym razie, warto spojrzeć.

no dobra te zamulenie tylko podczas gruba? czy podczas ladowania i dzialania systemu tez?

parametry jajka nic tu niepomoga przeciez to zamula jeszcze przed zaladowaniem jajka ;D

wlaz w biosa sproboj wylaczyc eufi albo poka jakie masz tam opcje

@groot
Jeżeli masz grafikę Intel-a, to zajrzyj tutaj https://wiki.archlinux.org/index.php/Intel_graphics_(Polski)
@LinGruby to wynalazł w sieci, u mnie to działa super.

Dobrze by było weryfikować treść w polskiej wersji (2017) czytając również angielską (2019) i, rzecz jasna, warto również zajrzeć na forum/wiki Manjaro. Sam, niestety, tego nie przestrzegam, ale kolejność powinna być taka: forum/wiki Manjaro -> forum/wiki Arch’a -> inne źródła.

Przpraszam za opóźnienie ale miałem przymusowy urlop od urządzeń elektornicznych :wink:

Udało mi się całkowicie problem wyeliminować. No może nie naprawiłem błędu ale skutecznie go omijam :slight_smile:

/etc/default/grub

....
# Uncomment one of them for the gfx desired, a image background or a gfxtheme
#GRUB_BACKGROUND="/usr/share/grub/background.png"
GRUB_THEME="/usr/share/grub/themes/manjaro/theme.txt"

Widząc taki wpis raczej nikt nie wpadł na pomysł, że tu może się coś dziać niewłaściwego, a jednak wystarczyło #GRUB_THEME="/usr/share/grub/themes/manjaro/theme.txt" i wszystko śmiga.

Nikt nie pomyślał, bo nie ma w tym niczego nieprawidłowego. GRUB_THEME= jest w porządku, działa i nie sprawia problemów. Używam go na wszystkich komp’ach, których dotykam swoją uzdrawiającą palczastością. Fakt, stosuję swój motyw, ale zanim go użyję, to jest domyślny i nie spotkałem się dotychczas z problemami. Wnoszę więc, że kłopoty nie dotyczą samej funkcjonalności, ale interakcji z jakimiś elementami systemu (sterowniki do karty graficznej?). Może, to wiązać się z funkcją GRUB_THEME=, jak i konkretnym motywem, w tym przypadku domyślnym /usr/share/grub/themes/manjaro/ .

pacman -Ql grub-theme-manjaro

forum.manjaro.pl - polskie wsparcie Manjaro. Hostowane przez: vpsadmin - hosting Discourse