Długie uruchamianie


#1

Od początku po instalacji Manjaro KDE muszę klikać jakikolwiek klawisz by się pojawił system na ekranie. Jak to poprawić? Włączam komputer i jest czarny ekran dopóki nie nacisnę dowolnego klawisza np: spację.


#2

Czy szukałeś na forum podobnych tematów? Do przeczytania


#3

sudo grub-editenv - unset menu_auto_hide
to nie pomogło, dalej się długo uruchamia i trzeba wciskać dowolny klawisz.


#4

To zdecyduj się bo ja tu widzę dwa tematy.

  1. Długie uruchamianie systemu.
  2. Czarny ekran przy uruchomieniu.

Musisz zobaczyć jaka usługa wydłuża start systemu. I znowu pytanie: Czy szukałeś na starym forum? Na przykład tutaj.
Nie bez powodu zadaję te pytania bo nie stosujesz sie do regulaminu forum a dokładnie do preambuły pkt. 2. Zanim zadasz pytanie…


#5

Czarny ekran przy uruchomieniu dopóki nie nacisnę np spacji. Wygląda to tak: włączam power i po diodach widzę ze dysk początkowo pracuje, po biosie wchodzi czarny ekran. Później dysk jakby nie pracował i czeka aż nacisnę spację i wtedy dysk rusza i włącza system. Jak nie nacisnę spacji to czarny ekran po biosie jest cały czas.


#6

Czyli mam rozumieć, że jak nie klikniesz to możesz czekać do tak zwanej " usra… śmierci" i system się nie włączy?
To, co mi przychodzi, to może ustawienie bootowania w biosie. Może jest tam jakaś opcja, że trzeba kliknąć by przejść na bootowanie z dysku gdy ustawione jest coś innego. A dwa to może jakieś ustawienia w configu gruba.

Pokaż zawartość:

/etc/default/grub

#7

Tak dokładnie jak nie kliknę to mogę czekać i czekać. Wynik zawartości pokaże po pracy, bo laptopa mam w mieszkaniu. Jeśli chodzi o ustawienia w biosie to raczej nie, bo tyle miałem systemów na tym laptopie i w żadnym tak nie było. Podejrzewam właśnie błąd w grubie, ale nie znam się, pierwszy raz coś takiego mam.
No i mam coś takiego:

[atari@..... ~]$ /etc/default/grub
bash: /etc/default/grub: Brak dostępu
[atari@..... ~]$

Zrobiłem: sudo update-grub
Nic to nie dało.


#8

@cizo żarty sobie robisz? Masz podać zawartość pliku grub, który znajduje się w /etc/default. Otwórz go w jakimś edytorze tekstowym, skopiuj zawartość i wklej tutaj. Zacznij używać znaczników code. Jeśli masz zamiar używać Linuksa musisz zapoznać się z podstawami.


#9

@cizo -> jeżeli masz polski system i dobrze pamiętam nazwę folderu (ja mam zmodyfikowane nazewnictwo, więc ‘Pulpit’ cytuję z pamięci), to wykonaj w terminalu:

$ cat /etc/default/grub > ~/Pulpit/grub.txt

gdzie ~/, to Twój katalog domowy, czyli zapewne /home/atari/.
Otwórz plik w manager’ze plików i wklej całą zawartość do tego wątku.


#10

Zainstaluj haveged:

sudo pacman -S haveged

albo rng-tools:

sudo pacman -S rng-tools

Niektórzy mówią, że ten drugi działa lepiej. Po instalacji zrób reboot i sprawdź czy pomogło.


#11

@michaldybczak nie pomogło


#12
GRUB_DEFAULT=saved
GRUB_TIMEOUT=5
GRUB_TIMEOUT_STYLE=menu
GRUB_DISTRIBUTOR='Manjaro'
GRUB_CMDLINE_LINUX_DEFAULT="quiet resume=UUID=a891a415-c2b4-4b2e-b8b7-1a86c016ef3c"
GRUB_CMDLINE_LINUX=""

# If you want to enable the save default function, uncomment the following
# line, and set GRUB_DEFAULT to saved.
GRUB_SAVEDEFAULT=true

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable booting from LUKS encrypted devices
#GRUB_ENABLE_CRYPTODISK=y

# Uncomment to use basic console
GRUB_TERMINAL_INPUT=console

# Uncomment to disable graphical terminal
#GRUB_TERMINAL_OUTPUT=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command 'videoinfo'
GRUB_GFXMODE=auto

# Uncomment to allow the kernel use the same resolution used by grub
GRUB_GFXPAYLOAD_LINUX=keep

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
GRUB_DISABLE_RECOVERY=true

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper
# modes only.  Entries specified as foreground/background.
GRUB_COLOR_NORMAL="light-gray/black"
GRUB_COLOR_HIGHLIGHT="green/black"

# Uncomment one of them for the gfx desired, a image background or a gfxtheme
#GRUB_BACKGROUND="/usr/share/grub/background.png"
GRUB_THEME="/usr/share/grub/themes/manjaro/theme.txt"

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"

Edit: @UltherEgo -> @cizo
proszę o korzystanie ze znacznika kodu.


#13

Szkoda, bo twój problem brzmiał jakby to było to.

W takim razie mam pytanie. Co oznacza, pojawienie się systemu wg ciebie? Pulpit czy ekran SDDM?
Zaczynam podejrzewać, że coś jest nie tak z ACPI i ekranem. Trudno określić czy to jakiś błąd i w logach można znaleźć czy to jakieś ustawienie, które można zmienić. To nie jest typowe zachowanie systemu.

Jeśli masz czarny ekran SDDM to może przełącz na inny DM i zobacz czy ten sam problem występuje.


#14

Od początku jak zainstalowałem system to tak mam. Pojawienie się systemu to wg mnie pojawienie się pulpitu i panelu itp


#15

Czyli masz ustawiony autologin? A sprawdź przypadkiem ustawienia ekranu blokady. Wyłącz go. Pewnie nic to nie zmieni, ale warto spróbować.
Brzmi to jednak jak problem ACPI, a to trudna sprawa, zdecydowanie wykraczająca poza moje kompetencje. Ale może komuś wpadnie coś do głowy i może to jednak coś innego.


#16

Po czystym uruchomieniu wpisz systemctl list-unit-files | grep enabled i podaj nam wynik.


#17

NetworkManager.service enabled
org.cups.cupsd.service enabled
sddm.service enabled
systemd-fsck-root.service enabled-runtime
tlp-sleep.service enabled
tlp.service enabled
avahi-daemon.socket enabled
org.cups.cupsd.socket enabled
remote-fs.target enabled


#18

Sprawdź z ciekawości czas startu systemu i podaj czy masz SSD czy HDD:

systemd-analyze


#19
Startup finished in 2.310s (kernel) + 2.335s (userspace) = 4.646s
graphical.target reached after 1.852s in userspace

mam SSD 128GB który ma 1 rok, chodził na nim ubuntu i było OK


#20

To przynajmniej pokazuje, że nie masz problemu z długim uruchamianiem, wręcz przeciwnie, system wstaje ci błyskawicznie.