Znikające ikony dodatków z paska narzędzi w Firefoksie

Jak w temacie. Po uruchomieniu przeglądarki nie wczytują się ikony rozszerzeń. Po wybraniu „Dostosuj pasek narzędzi” i zatwierdzeniu klikając „Gotowe” wszystko wraca do normy.
Support Mozilli sugeruje uszkodzony plik xulstore.json w katalogu profilu. Rozwiązaniem ma być jego usunięcie przed uruchomieniem Liska. Przeglądarka wygeneruje nowy. Zabieg ten niby działa, ale tylko przy pierwszym otwarciu programu, poza tym trzeba ponownie włączyć widoczność paska zakładek i menu.

System w pełni aktualny, środowisko KDE.

Ile masz rozszerzeń na pasku? Znalazłem gdzieś informacje, że zbyt duża ich ilość może powodować takie problemy. Spróbuj niektóre z nich ukryć lub wyłączyć.

Spróbuj przeinstalować Firefoxa i ponownie zastosować metodę z xulstore.json

Zmień (lub usuń) nazwę katalogu ~/.mozilla. Usunie to wszystkie ustawienia, historię itd. więc niestety trzeba będzie chwilę poświęcić na konfigurację, ale może pomóc.

Ile masz rozszerzeń na pasku? Znalazłem gdzieś informacje, że zbyt duża ich ilość może powodować takie problemy. Spróbuj niektóre z nich ukryć lub wyłączyć.

Sporo, ale nie sądzę by to była przyczyna. Prawie identyczne mam na windzie i tam problem nie występuje. Różnica to Plasma Integration i KDE Connect.

Spróbuj przeinstalować Firefoxa i ponownie zastosować metodę z xulstore.json

Reinstalacji nie robiłem, sprawdzę.
Edycja: Przeinstalowanie nie pomogło.

Zmień (lub usuń) nazwę katalogu ~/.mozilla . Usunie to wszystkie ustawienia, historię itd. więc niestety trzeba będzie chwilę poświęcić na konfigurację, ale może pomóc.

To już było. Nie pomogło.

Ale nie jest identycznie. Mimo wszystko bym sprawdził. Na początek przenieś kilka rozszerzeń do Menu ukrywania, a jak to nie pomoże, to wyłącz niektóre z nich.

Dzisiejsza aktualizacja systemu rozwiązała problem.

forum.manjaro.pl - polskie wsparcie Manjaro. Hostowane przez: