Zmiana karty graficznej na dedykowaną

Witam.
Przed chwilą zainstalowałem pierwszy raz manjaro.
Problem polega na tym, że jako domyślna ustawiła mi się karta zintegrowana zamiast dedykowana.
Moja karta to GeForce GT 840M
Jestem laikiem w manjaro także byłoby mi miło gdyby mi ktoś pomógł.
Wcześniej używałem pop_os i tam od razu karta była ustawiona na dedyka.

W zasadzie taka jest idea wynikająca z rozwiązania Nvidia Optimus dla zachowania jak najdłuższej pracy na baterii. TU masz trochę więcej informacji na temat grafiki w Manjaro. Od jakiegoś czasu zamiast Hybrid Bumblebee w Manjaro stosowany jest sterownik Hybrid Prime dla kart Nvidii obsługiwanych przez sterowniki 435.x w górę. Działa tak sobie, przynajmniej w mojej konfiguracji (mam taką samą kartę dedykowaną jak Ty).

W takim razie polecam zainteresować się Optimus Managerem (lub tutuaj)albo sterownikami 435x i nowszymi, które obsługują prime.

Integra jest ustawiona domyślnie, tak jak napisał @Manonfire ze względu na baterię – zużywa mniej energii.

A co powinien wybrać podczas instalacji manjaro w tym ekranie początkowym? Drivers Free czy nonfree?

Robię wszystko zgodnie z instrukacjami, które podesłaliście i wyskoczył mi taki błąd:

~ >>> optimus-manager --switch nvidia
ERROR: a GPU setup was initiated but Xorg post-start hook did not run.
Log at /var/log/optimus-manager/switch/switch-20200802T115408.log
If your login manager is GDM, make sure to follow those instructions:
https://github.com/Askannz/optimus-manager#important--gnome-and-gdm-users
If your display manager is neither GDM, SDDM nor LightDM, or if you don’t use one, read the wiki:
https://github.com/Askannz/optimus-manager/wiki/FAQ,-common-issues,-troubleshooting

Cannot execute command because of previous errors.

W takim razie zastosuj się do instrukcji z drugiego linku, który podałem wcześniej dla twojego środowiska graficznego albo do instrukcji, które masz w pierwszym linku komunikatu.

W przypadku Nvidii zwykle lepszym wyborem są sterowniki nonfree. Niemniej jednak nie trzeba od razu przeinstalowywać systemu, sterowniki możesz zmienić w każdej chwili w ustawieniach systemowych.

Czyli mam skorzystać z tego Prime? Tam nie jest za bardzo napisane jakich komend używać itp :confused: A ja jestem laikiem w tym jak napisałem wcześniej :confused:

Widzę, że nie do końca mnie zrozumiałeś, chodziło mi o ten link.

Jeśli chodzi o Prime to tam też są dość szczegółowe instrukcje jak to ustawić, jakie komendy wydać i jakie pliki zmienić, żeby na stałe korzystać z GPU Nvidii. Normalnie aby skorzystać z Nvidii musisz wydać polecenie prime-run program – oczywiście działa to tylko dla tego programu, a nie systemu jako całości.

To z którego wyjścia skorzystasz zależy od ciebie. Moim zdaniem Optimus jest wygodniejszy i łatwiejszy w obsłudze, no i łatwiej jest się przełączyć na inne GPU.

Teraz mam taki problem jak robię to z tego linku:

sudo systemctl disable bumblebeed.service
Failed to disable unit: Unit file bumblebeed.service does not exist.

Ok, w takim razie zacznijmy od ustalenia, jaki masz sprzęt i jakie sterowniki na pokładzie. Podaj wyniki poleceń:

inxi -Gxxx
mhwd -l
mhwd -li
systemctl status bumblebeed.service

inxi -Gxxx

Graphics:
Device-1: Intel HD Graphics 5500 vendor: Lenovo driver: i915 v: kernel
bus ID: 00:02.0 chip ID: 8086:1616
Device-2: NVIDIA GM108M [GeForce 840M] vendor: Lenovo driver: N/A
bus ID: 04:00.0 chip ID: 10de:1341
Display: x11 server: X.org 1.20.8 driver: N/A compositor: gnome-shell
v: 3.36.4 resolution:
OpenGL: renderer: Mesa Intel HD Graphics 5500 (BDW GT2) v: 4.6 Mesa 20.1.3
direct render: Yes

mhwd -l

0000:02:00.0 (0200:10ec:8168) Network controller Realtek Semiconductor Co., Ltd.:

              NAME               VERSION          FREEDRIVER           TYPE

     network-r8168            2016.04.20                true            PCI

0000:04:00.0 (0302:10de:1341) Display controller nVidia Corporation:

              NAME               VERSION          FREEDRIVER           TYPE

video-hybrid-intel-nvidia-440xx-prime 2019.10.25 false PCI
video-hybrid-intel-nvidia-435xx-prime 2019.10.25 false PCI
video-hybrid-intel-nvidia-430xx-bumblebee 2019.10.25 false PCI
video-hybrid-intel-nvidia-418xx-bumblebee 2019.10.25 false PCI
video-hybrid-intel-nvidia-390xx-bumblebee 2019.10.25 false PCI
video-hybrid-intel-nvidia-340xx-bumblebee 2019.10.25 false PCI
video-nvidia-440xx 2019.10.25 false PCI
video-nvidia-435xx 2019.10.25 false PCI
video-nvidia-430xx 2019.10.25 false PCI
video-nvidia-418xx 2019.10.25 false PCI
video-nvidia-390xx 2019.10.25 false PCI
video-nvidia-340xx 2019.10.25 false PCI
video-linux 2018.05.04 true PCI

0000:00:02.0 (0300:8086:1616) Display controller Intel Corporation:

              NAME               VERSION          FREEDRIVER           TYPE

video-hybrid-intel-nvidia-440xx-prime 2019.10.25 false PCI
video-hybrid-intel-nvidia-435xx-prime 2019.10.25 false PCI
video-hybrid-intel-nvidia-430xx-bumblebee 2019.10.25 false PCI
video-hybrid-intel-nvidia-418xx-bumblebee 2019.10.25 false PCI
video-hybrid-intel-nvidia-390xx-bumblebee 2019.10.25 false PCI
video-hybrid-intel-nvidia-340xx-bumblebee 2019.10.25 false PCI
video-linux 2018.05.04 true PCI
video-modesetting 2020.01.13 true PCI
video-vesa 2017.03.12 true PCI

mhwd -li

Installed PCI configs:

              NAME               VERSION          FREEDRIVER           TYPE

video-hybrid-intel-nvidia-440xx-prime 2019.10.25 false PCI

Warning: No installed USB configs!

systemctl status bumblebeed.service

Unit bumblebeed.service could not be found.

Ok, czyli używasz sterowników 440xx-prime, w takim razie zgodnie z poradnikiem pomijasz krok z wyłączeniem bumblebeed.service:

If you already use video-hybrid-intel-nvidia-440xx-prime configuration, this guide is also for you. The only difference is that you don't have bumblebee so you don't have to disable it. The rest of the guide stays the same. More info on hybrid off loading mode that this setup uses, see point 9.

Reszta przewodnika pozostaje taka sama. Uprzedzając inne potencjalne problemy – jeśli korzystasz z Gnome pomijasz punkt 6, a jeśli korzystasz z KDE pomijasz punkt 5 :wink:

Okej zrobiłem wszystko, teraz miałem ostatni punkt aby dodać optimus-manager-qt do programów uruchamianych przy starcie. Nie mogę tego zrobić, ponieważ wcale nie szuka mi programu optimus-manager-qt

Okej problem rozwiązany. Zainstalowałem optimus-manager-gt za pomocą trizen i pomogło. Wszystko działa jak należy na dedyku. Dzięki za pomoc. :slight_smile:

Jeśli korzystałeś z Pamaca i przy tym miałeś wyłączoną obsługę AUR to to jest zrozumiałe. Najpierw należy włączyć AUR w ustawieniach programu albo skorzystać z jakiegoś AURhelpera, jak to zrobiłeś :wink:

forum.manjaro.pl - polskie wsparcie Manjaro. Hostowane przez: vpsadmin - hosting Discourse