Uruchomienie mikrofonu wbudowanego w lapku

Jak sprawdzic czy mam mikrofon wbudowany w lapku?
I jak go uruchomic? Probowalem cos nagrac przy pomocy audacity i lipa.

W dokumentacji twojego laptopa, w ustawieniach systemowych (zależnie od posiadanego DE), w alsamixer, w Audacity (Pomoc > Diagnostyka > Informacje o urządzeniu…) i w wielu innych miejscach. W laptopach głośniki zwykle odpowiadają również za nagrywanie dźwięku.

Sprawdź ustawienia dźwięku w ustawieniach systemowych. Jeśli takowych nie ma (lub nie działają) sprawdź stan suwaków w alsamixer, możesz też skorzystać z pavucontrol.

z audacity

Nic mi to nie mowi, czy mam mikro wbudowany czy nie.

Na liście są urządzenia nagrywające, więc tak, masz mikrofon. Powinieneś sprawdzić ustawienia w alsamixer – być może mikrofon jest wyciszony.

No wyglada ze nie :frowning:

  1. NIe opowiedziałeś jakie masz środowisko graficzne i czy zainstalowane tam programy audio widzą mikrofon.
  2. Nie powiedziałeś czy zainstalowałeś pavucontrol i czy on widzi mikrofon.
  3. W alsamixer wciśnij F6 zobacz jekie masz tam możliwości i Internal Mic, jak u mnie jest wbudowanym. Jak podłączę słuchawki z mikrofonem to przełącza się na Mic Boost

1 xfce i czy widza mikrofon nie wiem co mam odpisac
2 pavu mam i takie cos pokazuje:

3 jak zrobie tak to mam internal zmutowany mm, wiec daje m zeby bylo 00 ale dalej nic nie moge nagrac ;/ Mimo ze na tym pierwszym screenie pokazuje juz glosnosc mikrofonu

Jak na razie wszystko wygląda w porządku (może poza głośnością, według mnie jest za cicho). Pokaż jeszcze, co masz w zakładce konfiguracja. Przetestuj też czy pavucontrol wykrywa dźwięk mikrofonu – jeśli podczas mówienia do komputera pasek pod wewnętrznym mikrofonem w zakładce Urządzenia wejściowe będzie się poruszał, to wszystko jest ok.

Może to być również kwestia ustawień Audacity czy innych programów do nagrywania – być może biorą dźwięk nie z tego urządzenia co trzeba – chociaż zwykle domyślne ustawienia są najlepsze :thinking:

nie działa
pasek nie porusza sie
(cos mnie trafia juz ;))

@Pan_Panan Sprawdź alsamixer według zaleceń @aquila.
Jeśli alsamixer nie wykryje mikrofonu, to mamy problem ze sterownikami, albo samym mikrofonem.
Zaś jeśli alsamixer wykryje urządzenie i go włączysz, będzie potrzebny restart PC, aby pavucontrol, mógł odnaleźć urządzenie (przeładować ustawienia, czasem wylogowanie nie pomaga). Jeśli odnajdzie ale po restarcie “nie utrzyma” ustawień, będzie konieczne wykonanie polecenia ‘alsactl store’.
Czy obrazując to:
Sprawdzamy `alsamixer’ F5 następnie F6 - wybieramy szukanego podzespołu, w którym znajduje się ustawienie mikrofonu. Na zdjęciu @aquila widzimy że pod zerem (0) znajduje się HDMI (ustawienia monitora, telewizora). Pod jedynką (1) ustawienia karty dźwiękowej.

Wykryło:

  1. Włączamy poprzez wciśnięcie “M” i podbijamy lekko do góry. Wychodzimy.
  2. Wpisujemy sudo alsactl store - nie pamiętam czy wymaga uprawnień sudo, czy też nie.
  3. Restart PC.
  4. Sprawdzamy pavucontrol

Wykryto ale po restarcie dalej nie widać w pavucontrol.

  1. Włączamy poprzez wciśnięcie “M” i podbijamy lekko do góry. Wychodzimy.
  2. Wpisujemy alsactl --file ~/.config/asound.state store.
  3. Do autostartu dodajemy alsactl --file ~/.config/asound.state restore.
  4. Restart PC i sprawdzamy pavucontrol

Nie wykryło:

  1. Sprawdź w manjaro-settings-manager czy masz zainstalowane sterowniki, jeśli nie doinstaluj. Jeśli tak, to spróbuj zmienić na zamknięte, ewentualnie inne.
  2. Będzie konieczne sprawdzenie w googlach informacji o karcie dźwiękowej i konfiguracji w manjaro.

forum.manjaro.pl - polskie wsparcie Manjaro. Hostowane przez: vpsadmin - hosting Discourse