UFW - status inactive and active


#1

GUFW nie chce się odpalić, więc odpalam w terminalu.

sudo systemctl enable ufw
sudo systemctl start ufw

Potem chcąc sprawdzić status wklejam:

sudo systemctl status ufw

Dostaję status enabled.

Jak sprawdzam status komendą:

sudo ufw status verbose

Dostaję wynik inactive.
Trochę dziwne. Zastanawia mnie ten wynik not enabled jak na załączonym obrazku.
Nie wiem, czy UFW jest włączony, czy nie. Mógłby ktoś rzucić okiem?ufw


#2

Rzuciłem okiem na manjaro wiki i pomogła komenda:

sudo ufw enable


#3

A sprawdż czy masz uruchomiony iptables

sudo systemctl status iptables

A tak w ogóle to coś masz zle ustawione w tym ufw, bo prawidłowo to powinno tak wyglądać

● ufw.service - CLI Netfilter Manager
   Loaded: loaded (/usr/lib/systemd/system/ufw.service; enabled; vendor preset: disabled)
   Active: active (exited) since Tue 2019-01-29 12:04:55 CET; 25min ago
  Process: 293 ExecStart=/usr/lib/ufw/ufw-init start (code=exited, status=0/SUCCESS)
 Main PID: 293 (code=exited, status=0/SUCCESS) 

Natomiast verbose tak

Status: active
Logging: on (low)
Default: deny (incoming), allow (outgoing), disabled (routed)
New profiles: skip

To                         Action      From
--                         ------      ----
22/tcp                     ALLOW IN    Anywhere                  
22                         ALLOW IN    Anywhere                  
22/tcp (v6)                ALLOW IN    Anywhere (v6)             
22 (v6)                    ALLOW IN    Anywhere (v6) 

#4

@robson75 -> jeżeli używasz ufw, to nie możesz mieć uruchomionego iptables.service - wiki nie wyjaśnia dlaczego, ale najprawdopodobniej konfliktują ze sobą.
Nie widzę problemu z ustawieniami service’u. Oboje macie ‘enabled’ i ‘active’.
Co do komendy ufw status verbose, to prawdopodobnie @braciszekodd zacytował tylko fragment odpowiedzi programu.


Podsumowując, po lekturze wiki Manjaro i Arch’a, oraz własnych testach:

  • sprawdzamy, czy iptables.service jest wyłączony:
$ sudo systemctl status iptables
  • jeżeli działa, to wyłączamy:
$ sudo systemctl disable iptables
$ sudo systemctl stop iptables
  • uruchamiamy ufw.service:
$ sudo systemctl enable ufw
$ sudo systemctl start ufw
  • uruchamiamy firewall’a:
$ sudo ufw enable

Skutkuje, to zmianą wpisu w pliku konfiguracyjnym (no -> yes) i uruchamianiem programu podczas startu systemu:

/etc/ufw/ufw.conf
---------------------------------
ENABLED=yes
  • używamy, konfigurując firewall’a, czy instalując inne programy, korzystające z iptables i/lub ufw albo będące graficznymi nakładkami (np. gufw).

#5

@azja właśnie o tym pisze, ja np. aktywowałem ufw, i za jakiś czas aktywowałem iptables. I dopiero po jakimś czasie zorientowałem się że ufw jest nieaktywny, a to za sprawą iptables.
Dlatego proponowałem sprawdzenie statusu iptables.

Edit:
Proponuje zajrzeć tutaj
https://www.hiroom2.com/2017/07/16/linuxmint-18-ufw-en/


#6

Być może masz ten sam problem z GUFW, który swego czasu miałem i który udało się rozwiązać: https://manjaro.pl/forum/topic/gufw-nie-uruchamia-sie/


#7

ufw jest nakładką na iptables, zaś gufw to graficzna nakładka na ufw.

Przy stosowaniu ufw trzeba wyłączyć iptables:

$ sudo systemctl status iptables
$ sudo systemctl stop iptables
$ sudo systemctl disable iptables

Teraz włączamy ufw:

$ sudo systemctl enable ufw     # autostart 
$ sudo ufw enable  # włączamy ufw

Lub skorzystaj z gufw


#8

Panowie, dziękuję za wsparcie.

UFW działa, iptables wyłączone jak na załączonym obrazku.UFW-solved