Sterownik nVidia nouveau/instalacja nvidia legacy

Po długiej, krwawej i niestety przegranej walce z porzuconymi sterami do mojej karty w Latitude E6400 (nVidia Quadro NVS 160m) zainstalowałem nouveau. Chylę czoła przed twórcami, bo bez dokumentacji (niby nVidia coś tam pomogła) stworzyli coś, co działa. Niestety, działa tak, że przy oglądaniu filmu z jutuba lapek zaczyna wydawać dźwięki startującego B52 z pełnym obciążeniem. Generalnie wszystko, co wymaga jakiejś akceleracji graficznej idzie na CPU (C2D). Cudów się nie spodziewam, ale chyba coś jest nie tak.

Polecam :slight_smile:

2 polubienia

W zasadzie nic mam do stracenia, więc skorzystam. Dzięki

Powodzenia :slight_smile:
U mnie na blaszaku z jądrem 5.4 poszło bez problemów. Nvidia 340xx.

Działa!!! Dzięki wielkie, lapek odzyskał swoją kartę graficzną.

Na 5.10 sprzed kilku dni też działa.
Dzięki za wskazówkę.

inxi -G:
Graphics: Device-1: NVIDIA GT218 [GeForce 210] driver: nvidia v: 340.108
Display: x11 server: X.Org 1.20.10 driver: loaded: nvidia unloaded: modesetting,nouveau resolution: 1920x1080~60Hz
OpenGL: renderer: GeForce 210/PCIe/SSE2 v: 3.3.0 NVIDIA 340.108

1 polubienie

Potwierdzam. Działam teraz na 5.10

Podepnę się pod temat. Zainstalowałem sterowniki Nvidia zgodnia z powyższym linkiem natomiast od razu pokazała mi się dziwna aktualizacja z AUR-a


Jest ona niepotrzebna. Czy jest jakiś sposób żeby ta aktualizacja się nie pokazywała bez wyłączania AUR-a i jego aktualizacji?

Tak jest. Należy podbić release paczki, wyedytuj PKGBUILD, a dokładnie linię pkgrel w nim…

Mabox_2021-01-25-20:22:1611602555

i przebuduj.

Zresztą jest to opisane w linkowanym Howto:
You may need to recompile this package as soon as we add a new kernel and also don’t forget to bump the PKGREL.

czyli pkgrel z 13 na 14 - mam rację?

Nie do końca… 13 jest w AUR, na githubie philmmanjaro pkgrel był 1 (przynajmniej kilka dni temu jeszcze)
więc bardziej z 1 na 14.
Ważne żeby numer release zbudowanej paczki był wyższy niż dostępnej w AUR.
Wtedy menadżer pakietów czy tam AUR helper nie będzie proponował jej aktualizacji.

Coś źle robię albo nie rozumiem. mój plik PKGBUILD feralnego pakietu wygląda tak:

# Maintainer: Jerry Xiao <aur@mail.jerryxiao.cc>
# Maintainer: graysky <graysky AT archlinux DOT us>
# Contributor: Giancarlo Razzolini <grazzolini@archlinux.org>
# Contributor: Eric Bélanger <eric@archlinux.org>

pkgbase=nvidia-340xx
pkgname=(nvidia-340xx nvidia-340xx-dkms)
pkgver=340.108
pkgrel=13
pkgdesc="NVIDIA drivers for linux, 340xx legacy branch"   
arch=('x86_64')
url="https://www.nvidia.com/"
makedepends=("nvidia-340xx-utils=${pkgver}" 'linux>=5.5' 'linux-headers>=5.5')
conflicts=('nvidia')
license=('custom')
options=(!strip)
source=("https://us.download.nvidia.com/XFree86/Linux-x86_64/${pkgver}/NVIDIA-Linux- 
x86_64-${pkgver}-no-compat32.run"
0001-kernel-5.7.patch

klikam Zbuduj, potem Zastosuj. Następnie prośba o hasło. Pokazuje mi się okienko podsumowanie operacji, klikam przycisk Edytuj pliki budowania - zmieniam opcję pkgrel=13 na pkgrel=14 w pliku PKGBUILD Kikam zapisz, następnie znów okienko podsumowania operacji klikam Zastosuj i system znów próbuje niestety instalować pakiet co mu się nie udaje.

Przygotowanie…
Kopiowanie nvidia-340xx plików kompilacji…
Sprawdzanie nvidia-340xx-dkms zależności…
Synchronizacja baz danych pakietów…
Rozwiązywanie zależności…
Sprawdzanie konflików między pakietami…
Edit nvidia-340xx build files

Kopiowanie nvidia-340xx plików kompilacji…
Sprawdzanie nvidia-340xx-dkms zależności…
Rozwiązywanie zależności…
Sprawdzanie konflików między pakietami…

Budowanie nvidia-340xx…
/var/tmp/pamac-build-majster/nvidia-340xx/PKGBUILD: linia 32: /usr/src/linux/version: Nie ma takiego pliku ani katalogu
==> Tworzenie pakietu: nvidia-340xx 340.108-13 (pon, 25 sty 2021, 22:29:22)
==> Sprawdzanie zależności potrzebnych do uruchomienia…
==> Sprawdzanie zależności potrzebnych do budowy…
==> Pobieranie źródeł…
→ Pobieranie NVIDIA-Linux-x86_64-340.108-no-compat32.run…
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed

0 0 0 0 0 0 0 0 --:–:-- --:–:-- --:–:-- 0
2 36.9M 2 1088k 0 0 5256k 0 0:00:07 --:–:-- 0:00:07 5230k
42 36.9M 42 15.7M 0 0 13.0M 0 0:00:02 0:00:01 0:00:01 13.0M
82 36.9M 82 30.5M 0 0 13.8M 0 0:00:02 0:00:02 --:–:-- 13.8M
100 36.9M 100 36.9M 0 0 13.9M 0 0:00:02 0:00:02 --:–:-- 13.9M
→ Znaleziono 0001-kernel-5.7.patch
→ Znaleziono 0002-kernel-5.8.patch
→ Znaleziono 0003-kernel-5.9.patch
→ Znaleziono 0004-kernel-5.10.patch
==> Sprawdzanie plików source za pomocą b2sums…
NVIDIA-Linux-x86_64-340.108-no-compat32.run … Zgadza się
0001-kernel-5.7.patch … Zgadza się
0002-kernel-5.8.patch … Zgadza się
0003-kernel-5.9.patch … Zgadza się
0004-kernel-5.10.patch … Zgadza się
==> Usuwanie istniejącego katalogu $srcdir/…
==> Rozpakowywanie źródeł…
==> Rozpoczynanie prepare()…
Creating directory NVIDIA-Linux-x86_64-340.108-no-compat32
Verifying archive integrity… OK
Uncompressing NVIDIA Accelerated Graphics Driver for Linux-x86_64 340.108…
patching file kernel/Makefile
patching file kernel/conftest.sh
patching file kernel/dkms.conf
patching file kernel/nv-drm.c
patching file kernel/nv-linux.h
patching file kernel/nv-procfs.c
patching file kernel/nv-time.h
patching file kernel/nv.c
patching file kernel/os-interface.c
patching file kernel/uvm/Makefile
patching file kernel/uvm/conftest.sh
patching file kernel/uvm/nvidia_uvm_lite.c
patching file kernel/nv-linux.h
patching file kernel/nvidia-modules-common.mk
patching file kernel/os-mlock.c
patching file kernel/uvm/nvidia_uvm_lite_api.c
patching file kernel/nv-drm.c
patching file kernel/nv-linux.h
patching file kernel/nv.c
patching file kernel/uvm/nvidia_uvm_linux.h
patching file kernel/nv-drm.c
Hunk #1 succeeded at 364 (offset 42 lines).
==> Rozpoczynanie build()…
NVIDIA: calling KBUILD…
make[1]: *** /usr/src/linux: Nie ma takiego pliku ani katalogu. Stop.
NVIDIA: left KBUILD.
nvidia.ko failed to build!
make: *** [Makefile:202: nvidia.ko] Błąd 1
==> BŁĄD: Wystąpił błąd w build().
Przerywam…

Pakiet wciąż chce się instalować

Czy tak trudno jest przekleić do konsoli osiem poleceń z poradnika?
Po prostu zrób to co tam jest opisane, a nie kombinuj.

Twój PKGBUILD nie pochodzi z tego poradnika.

Chyba się nie rozumiemy
zrobiłem dokładnie to:
Prepare your system for building drivers

  • you may want to install development tools: sudo pacman -S git base-devel
  • then you may want to install your proper kernel headers: sudo pacman -S $(mhwd-kernel -li | grep '*' | cut -d ' ' -f5 | awk '{print $0,"-headers"}' | sed s'/ //'g)

340xx (dkms 5.4 - 5.10)

You need to get the sources first:

 git clone https://gitlab.manjaro.org/packages/extra/nvidia-340xx-utils.git
 git clone https://gitlab.manjaro.org/packages/multilib/lib32-nvidia-340xx-utils.git
 git clone https://github.com/philmmanjaro/nvidia-340xx-dkms.git

Then compile all packages with makepkg:

 cd nvidia-340xx-utils && makepkg -si
 cd ../lib32-nvidia-340xx-utils && makepkg -si
 cd ../nvidia-340xx-dkms && makepkg -si

Wszystko było w porządku ale po ostatnim poleceniu wczytał mi się ten pakiet z AUR do instalacji. Jak się tego pozbyć?

Pełną odpowiedź masz pod swoim pierwszym postem.

Jeśli nie jesteś w stanie jej przeczytać, zrozumieć i wykonać to bardzo mi przykro, ale nie jestem w stanie pomóc.

A jak ci się “wczytał pakiet z AUR” (jakim cudem i po co?) to po prostu go usuń, i wykonaj wszystko od nowa z podbiciem pkgrel.

@majster po wydaniu polecenia:

 git clone https://github.com/philmmanjaro/nvidia-340xx-dkms.git

w katalogu w którym pracujesz (zwykle będzie to twój domowy katalog) utworzy się katalog nvidia-340xx-dkms – w tym katalogu znajduje się PKGBUILD, który masz wyedytować. Ważne, żebyś zrobił to od razu, zanim przejdziesz do kolejnych poleceń. Ot cała filozofia :wink:

Ano właśnie. A ja próbowałem edytować nie ten pakiet. Dziękuję za poświęcony czas

forum.manjaro.pl - polskie wsparcie Manjaro. Hostowane przez: vpsadmin - hosting Discourse