Ruch myszy powoduje fps drop w grach i podbija użycie procesora

Witam. Jestem nowym użytkownikiem manjaro i od razu niestety napotkałem problem, z którym z tego co wyczytałem w internecie borykało się już parę osób ale nie bardzo wiem jak sobie z tym poradzić (nie ogarniam jeszcze na tyle linuxa :frowning: ) . Otóż problem polega na tym, że poruszanie myszką podczas grania (btw system siedzi na lapku i touchpad generuje ten sam problem) powoduje znaczne obniżenie fps (nie we wszystkich grach np. w gothicu 1 i 2 obniża, w spellforce platinum edition steam natomiast ruszanie myszką dodaje fps ale gra niestety i tak laguje mocno, znacznie mocniej niż bardziej wymagające gry, a na przykład w spellforce 2 ze steam już ten problem nie jest tak duży) ponadto zauważyłem w monitorze zasobów, że nawet powolny ruch myszki podbija użycie procka do ponad 40% na obu rdzeniach. Wyczytałem, że wyłączenie przyspieszenia sprzętowego dla myszki może rozwiązać problem ale nie wiem jak to zrobić. Próbowałem obniżyć pooling rate dla myszki według instrukcji na ArchWiki ale system i tak zostawia wartość domyślną z resztą chyba nie tędy droga, gdyż myszka lata na 250hz, a touchpad na około 100hz według terminala po wpisani sudo ehvz (paczka ściągnięta z AUR), a obydwoje psują rozgrywkę. Ponad to w każdej grze kursor myszy zarówno w menu gry jak i podczas rozgrywki dynamicznie miga, a gdy nie ruszam myszką to wcale go nie widać. Nie grzebałem nic więcej w ustawieniach, sterowniki standardowe (zintegrowany intel) i zawsze aktualizowane. Tylko nie mówcie, że to wina grafiki na Windowsie w/w gry śmigały bez zarzutu :stuck_out_tongue: . Dodam jeszcze, że zmiana wersji Wine i Proton na starsze nic nie daje, problem objawia się wciąż tak samo jak na nowszych wersjach. Bardzo was drodzy forumowicze proszę o pomoc i ewentualne łopatologiczne wytłumaczenie co muszę zrobić aby pozbyć się tego problemu.

Skoro to integra to czy obok jest GPU? Jeśli tak to na jakich sterownikach?

Możesz kierować się Arch Wiki, ale w XFCE są odpowiednie opcje, poklikaj.

To mi wygląda na kwestię ustawień kompozytora – poeksperymentuj z ustawieniami.

Z tego rozumiem, że problem dotyczy tylko gier odpalanych przez Wine/Proton – w takim razie polecam zajrzeć na ProtonDB oraz na dyskusje na Steamie, być może inni gracze natknęli się na podobny problem i znaleźli rozwiązanie.

1 polubienie

Bardzo dziękuję za odpowiedź :slight_smile:. No więc po kolei. Obok integry nie ma żadnej karty, tylko od intela. Zmiana ustawień w opcjach XFCE nic nie zmienia. Ustawieniami kompozytora się nie bawiłem, dzięki za podpowiedź zaraz wypróbuje. Tak problem dotyczy tylko gier z Wine i z Proton. Na protonDB szukałem i nic nie znalazłem. Był jeden temat pod spellforce z migającym kursorem ale został zamknięty, gdyż u tego użytkownika pomogła sama aktualizacja protona do nowszej wersji. A w innych grach wystarczyło wejść do ustawień gry i wyłączyć HW acceleration ale w w/w grach takich ustawień brak. Wydaje mi się, że problem jednak leży po stronie mojego laptopa, ponieważ na ubuntu było identycznie i na linux mint też. Przesiadłem się na manjaro bo lepiej sobie radzi ze sterownikami co słychać po samej jakości dźwięku, gdy puszczam muzykę i w manjaro mogę odpalać gry we wszystkich wersjach protona a na ubuntu mimo zainstalowania wszystkich sterowników i bibliotek do vulkana i dxvk tylko starsze wersje protona pozwalały na uruchamianie gier. Czy to możliwe, że po prostu te problemy wynikają z tego, że linux słabiej sobie radzi z tego typu kartami? Problem jest zauważalny nawet ruszając myszką po pulpicie przy włączanym menadżerze zaczyna mi mocniej pracować procesor bez włączonych innych aplikacji tzn. mysz chodzi normalnie bez wizualnych przypadłości ale jednak użycie procesora skacze do góry, dziś zauważyłem, że do ponad 60% użycia podbija co podczas grania może go męczyć zanadto. A propos tych ustawień w kompozytorze. Podpowiesz mi na co zwrócić uwagę? Które ustawienie może za to odpowiadać? Czy po prostu wyłączyć wszystkie dodatkowe bajery i efekty?
Edit:

Więc chyba nie mogę znaleźć tych ustawień. W moim menadżerze okien brak takich ustawień i nie mogę ich nigdzie znaleźć. Musze coś pobrać dodatkowo żeby je mieć?

Edit 2:
Wybacz nie ogar jestem xD. Znalazłem te ustawienia przeszukując paczki do zainstalowania i okazało się, że mam już to zainstalowanie tylko troszkę inaczej to wygląda xD. Niestety nic to nie daje. Wyłączyłem wszystkie kompozycję ale wciąż kursor mryga w grach i ruch myszki powoduje spadek fps i podbija użycie procesora :frowning:. Nie mam pojęcia co to może być :frowning:.

Całkiem możliwe, że to wina słabego sprzętu. Intel Celeron N2840 to jednak dość słaby sprzęt i może sobie nie radzić z Protonem i Wine. Jakby nie patrzeć w porównaniu do natywnych gier jest to dodatkowa warstwa, z którą procesor musi sobie poradzić.

Włączyć zbędne wodotryski. A jeśli masz odpowiednie opcje to również zmienić silnik wyświetlania albo sposób skalowania okien. Tak samo może pomóc wyłączenie przezroczystości, cieni czy innych bajerów w innych miejscach – zmniejszy to obciążenie procesora.

To, że podczas ruszania myszką zużycie procesora rośnie jest oczywiste, w końcu obraz się zmienia, nie jest statyczny. Pytanie o ile procent skacze zużycie – jeśli z kilku procent to coś może być na rzeczy. Na moim procku (Intel i5-4200H, z tego samego okresu twój, ale mocniejszy) wzrasta o mniej więcej 10%, na słabszym sprzęcie może to być więcej.

Tego się właśnie obawiałemm :frowning:. Naprawdę nie chcę wracać do windy tylko po to, żeby móc pograć bo na windowsie wszystko inne działa gorze, a jeśli chodzi o gry natywne to na przykład dota 2 na windzie na low detalach śmigała normalnie, na ubuntu nie dało się grać, na manjaro jest znośnie jednak ilość fps nie pozawala cieszyć się rozgrywką podczas teamfightów. (na vulkanie nie chce się uruchomić wcale tylko na opengl mimo, że w sieci teoretycznie sprawdzałem, że mam wsparcie vulkana, chyba że jest to tylko częściowe wsparcie i dlatego tak się dzieję).

Wyłączyłem wszystkie kompozycje, zmiana innych ustawień też niestety nic nie daje :frowning:.

Użycie procesora z włączonym tylko terminalem podczas ruszania myszką skacze z 5%-10% do nawet 68% na obydwu rdzeniach na raz, dlatego wydaje mi się to dziwne nie jest to kilka procent tylko kilkadziesiąt.

Całkiem możliwe, też mam iGPU + Nvidię, na Intelu tylko częściowe wsparcie dla Vulkana. Działało, ale tak średnio – pamiętam jak rok temu próbowałem uruchomić Talos Principle, który wymaga Vulkana do działania, na Intelu – uruchamiał się raz na kilka razy. Na szczęście akurat pojawiły się sterowniki prime i problem zniknął (wcześniej co prawda kombinowałem z Optimusem, ale trochę przekombinowałem i dałem sobie spokój). W ogóle, wsparcie dla Vulkana sprawdzisz sobie poleceniem vulkaninfo albo w Steamie Pomoc > Informacje systemowe – tam przy okazji znajdziesz dodatkowe informacje z innych technologii (np. OpenGL)

To faktycznie trochę dużo.

Faktycznie wynik z vulkan info: INTEL-MESA: warning: Bay Trail Vulkan support is incomplete
Czyli nie mam pełnego wsparcia ale to nie duży problem z openGL jak odpalam gry to uruchamiają się normalnie.

Masz może jakieś pomysły jak temu zaradzić? Może da się w kernelu albo przez jakąś aplikację wyłączyć przyspieszenie sprzętowe dla myszki całkiem? (nie tylko zmienić szybkość przewijania i poruszania się myszki).

Mogę jedynie odesłać do Arch Wiki, innych pomysłów nie mam.

No właśnie sposób z Archwiki nie działa :frowning:. Wygląda na to, że będę musiał z tym jakoś żyć dopóki nie złożę na nowo swojego PC. Tak czy inaczej dziękuję Ci bardzo za zainteresowanie tematem :slight_smile:.

@Maki55, próbowałeś w ogóle wyłączyć Kompozytora?

Kompozycje / Włączenie (-> wyczyścić opcję)


Jest jeszcze xfce4-settings-editor, w którym są wszystkie ustawienia w ‘czystej’ postaci - być może znajdziesz tam coś, czego nie ma w GUI,

Owszem i niestety nie pomogło.

Dzięki za podpowiedź, tam jeszcze nie grzebałem.

forum.manjaro.pl - polskie wsparcie Manjaro. Hostowane przez: vpsadmin - hosting Discourse