Problem z uruchomieniem GG w Manjaro

Witam .

Mam problem z zainstalowaniem kadu z pomocą pamac-manager
Wyskakuje mi coś takiego :


Przygotowywanie...
Kopiowanie kadu plików kompilacji...
Sprawdzanie kadu zależności...

Budowanie kadu...
==> Tworzenie pakietu: kadu 4.3-1 (pon, 7 paź 2019, 12:10:36)
==> Sprawdzanie zależności potrzebnych do uruchomienia...
==> Sprawdzanie zależności potrzebnych do budowy...
==> Pobieranie źródeł...
  -> Pobieranie kadu-4.3.tar.bz2...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed

 ....
  0     0    0     0    0     0      0      0 --:--:--  0:02:09 --:--:--     0
curl: (7) Failed to connect to download.kadu.im port 80: Przekroczony czas oczekiwania na połączenie
==> BŁĄD: Błąd podczas pobierania http://download.kadu.im/stable/kadu-4.3.tar.bz2
    Przerywam...

System to : manjaro Juhraya 18.1.0 x64

Specka :

Dell Latitude E6230 .OS Manjaro Linux 18.04 Illyria
Specyfikacja :
RAM : 2x 2GB 1066MHz
CPU - Intel Core i5 3320M
HDD - Seagate ST2000LM007 2 TB
WiFi - Intel® Dual Band Wireless-AC 7260
LAN - Intel® 82579LM Gigabit Network Connection
2x USB 3.0
1xUSB 2.0 | Combo eSATA
1x HDMI

Z góry dziękuje za pomoc :slight_smile: .

curl: (7) Failed to connect to download.kadu.im port 80: Przekroczony czas oczekiwania na połączenie
==> BŁĄD: Błąd podczas pobierania http://download.kadu.im/stable/kadu-4.3.tar.bz2

Nic ani nikt na to nic nie poradzi, po prostu strona nie działa.

Proponuje zbudować ekg.

aur/kadu 4.3-1 (+1 0.00%) (Orphaned) 
    Qt-based Jabber/XMPP and Gadu-Gadu client

Wygląda na pakiet porzucony. (https://aur.archlinux.org/packages/kadu/)
Ostatnia aktualizacja z 2018-02-09 22:58.

Strona nie odpala …
Apropo próbowałem nawet gg . Pobieram i wypakowuję i nie odpala wogle … Odpalony na bieżąco menedżer zadań i nawet procesu nie ma gg…
Pidgin mi nie łyka gg . Wklepuje nr gg i hasło i nic ; …

Weź sobie zbuduj Ekg.

Nie wiem jak :smiley: ale sobie poszukam …

Po prostu uruchom pamaca i wpisz ekg.

Przy ekg mam to :

Przygotowywanie…
Kopiowanie ekg plików kompilacji…
Sprawdzanie ekg zależności…

Budowanie ekg…
==> Tworzenie pakietu: ekg 20190803-1 (pon, 7 paź 2019, 14:37:30)
==> Sprawdzanie zależności potrzebnych do uruchomienia…
==> Sprawdzanie zależności potrzebnych do budowy…
==> Pobieranie źródeł…
-> Pobieranie ekg-20190803.tar.gz…
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed

0 0 0 0 0 0 0 0 --:–:-- --:–:-- --:–:-- 0
0 0 0 0 0 0 0 0 --:–:-- --:–:-- --:–:-- 0
100 288 100 288 0 0 878 0 --:–:-- --:–:-- --:–:-- 875

100 124 100 124 0 0 298 0 --:–:-- --:–:-- --:–:-- 298
==> Sprawdzanie plików source za pomocą md5sums…
ekg-20190803.tar.gz … NIE ZGADZA SIĘ
==> BŁĄD: Przynajmniej jeden plik nie jest poprawny!

Main Got
To w takim razie pobierz snapshota z tej strony którą Ci podałem, następnie rozpakuj ten plik i otwórz ten PKGBUILD w jakimś edytorze tekstowym, i w miejscu md5sums wpisz SKIP jak poniżej

md5sums=('SKIP') 

I zapisz, następnie uruchom terminal i wpisz makepkg -sirc

Jeśli chcesz korzystać z gg, to jest jeszcze możliwość kopete + libgadu oba w repozytorium extra.

Jak ty odpalasz to oryginalne gg? Ściągnąłem paczkę i normalnie się uruchamia.
Ściągasz spakowany katalog GG z
https://www.gg.pl/#talk-everywhere (odpowiednią wersję)
przechodzisz do katalogu gdzie się ściągnęło i rozpakowujesz. Po rozpakowaniu odpalasz konsolę i wchdzisz do katalogu GG i odpalasz skrypt poleceniem
./gg
wyskoczy monit o instalację Adobe Flash 10.3, ale ignorujesz i pojawia się okno logowania, jak na zrzucie ekranu

Sprawdziłem z ciekawości. Na domyślnych ustawieniach dodałem nr oraz hasło … i działa.
Spróbuj może reinstalować pidgin

Nie mam pojęcia co jest ale mi nawet gg nie odpala :smiley: ? Dziwne … W terminalu wklepuje ./gg i zero reakcji

Coś musisz robić nie tak. W terminalu najpierw musisz wejść do rozpakowanego katalogu. Jeśli nic nie przenosiłeś po ściągnięciu i rozpakowaniu to powinien być w pobranych więc w terminalu wpisujesz
cd Pobrane/GG i enter
a potem dopiero wpisujesz
./gg i enter

Zawartość wątku uległa zmianie, w stosunku do jego nazwy, ale widzę w tym sens, więc pozwoliłem sobie na zmianę tytułu, tak aby odpowiadał treści.


Kadu jest, niestety, martwym projektem. Autor przestał go rozwijać (może zmęczył się, a może ma ważniejsze sprawy na głowie), a ne znalazł się nikt chętny do przejęcia kodu i poprowadzenia projektu dalej. Szkoda, bo to kawałek dobrego oprogramowania. R.I.P. Kadu :frowning:


Soft ze strony GG (do którego link’ował @wiini) działa i wygląda sensownie (propozycja instalacji Flash’a trochę psuje efekt). Sugeruję więc taką kolejność działań:

  1. Ściągamy oprogramowanie [1]:
    https://im-updates.gg.pl/files/release/linux64
  2. Rozpakowujemy je w katalogu [2] ~/bin/
    tak aby uzyskać ~/bin/GG/
  3. Tworzymy aktywator [3]:
gg.desktop
[Desktop Entry]
Version=1.0
Type=Application
Name=gg
GenericName=gadu-gadu
Comment=dowolny komentarz, jaki zechcemy dołączyć
TryExec=
Exec=/home/nazwa_mojego_usera/bin/GG/gg
Icon=/home/nazwa_mojego_usera/bin/GG/icons/gg.png
Path=
Categories=Network;Office;
Terminal=false
StartupNotify=true
MimeType=
  1. Przenosimy go do ~/.config/applications/
  2. Cieszymy się obecnością GG w menu.

[1] Bezpośredni link do tego samego, co wyżej link’ował @wiini .
[2] Folder może mieć dowolną nazwę. Ważne, aby był przeznaczony do binarek i skryptów, jakie trzymamy we własnym katalogu domowym.
[3] Plik text’owy.
[-] Konfiguracja i dane przechowywane, są w ~/.config/gg/

Wybaczcie za nieodzew ale winowajcą jest ruter :smiley: Umiejscowienie …

A wracając do tematu . Miałem coś namieszane w manjaro i dlatego mi nie trybiło gg …
Jestem po reinstalacji i za chwilę spróbuję jeszcze raz :smiley:

Na prośbę jednego z użytkowników (nie tego forum) pomocy w utworzeniu pakietu Kadu, takowy powstał. Program od dwóch lat nie jest rozwijany więc lepiej zastosować opisane wyżej w tym wątku alternatywy. Jeśli jednak ktoś nie może żyć bez Kadu (jak wspomniany przeze mnie kolega) to wrzucam linki do pobrania:
kadu
kadu-common
libkadu

Instalacja:

Na poczatek musimy zbudować pakiety: qxmpp, injeqt z AUR (sobie tylko znanym sposobem yay, trizen, pamac itp.)

Potem:

sudo pacman -U ściągnięte pakiety

GTK -owcom przypomnę, Kadu wymaga bibliotek Qt więc ściągnie sporo dodatkowych pakietów.

sudo pacman -U /home/aquilapl/Pobrane/kadu/kadu-4.1-1-x86_64.pkg.tar.xz /home/aquilapl/Pobrane/kadu/kadu-common-4.1-1-any.pkg.tar.xz /home/aquilapl/Pobrane/kadu/libkadu-4.1-1-x86_64.pkg.tar.xz
wczytywanie pakietów…
rozwiązywanie zależności…
szukanie sprzecznych pakietów...
ostrzeżenie: wykryto cykl zależności:
ostrzeżenie: lib32-keyutils zostanie zainstalowane przed zależnościami lib32-krb5

Pakiety (70) cblas-3.8.0-2  cdparanoia-10.2-7  crossover-18.5.0-3  graphene-1.10.0-1
             gst-plugins-base-1.16.1-1  lib32-alsa-lib-1.1.9-1  lib32-e2fsprogs-1.45.4-1
             lib32-flac-1.3.3-1  lib32-gmp-6.1.2-2  lib32-gnutls-3.6.10-1
             lib32-keyutils-1.6-1  lib32-krb5-1.17-1  lib32-libasyncns-0.8+3+g68cd5af-2
             lib32-libcups-2.3.0-1  lib32-libidn-1.35-1  lib32-libjpeg6-turbo-1.5.3-1
             lib32-libldap-2.4.48-1  lib32-libltdl-2.4.6+42+gb88cebd5-1
             lib32-libogg-1.3.4-1  lib32-libpng12-1.2.59-1  lib32-libpulse-13.0-1
             lib32-libsndfile-1.0.28-2  lib32-libtasn1-4.14-1  lib32-libvorbis-1.3.6-1.1
             lib32-libxcomposite-0.4.5-1  lib32-libxinerama-1.1.4-1
             lib32-libxslt-1.1.33-1  lib32-libxtst-1.2.3-2  lib32-mpg123-1.25.13-1
             lib32-nettle-3.5.1-1  lib32-nss-mdns-0.14.1-1  lib32-openal-1.19.1-1
             lib32-openssl-1:1.1.1.d-1  lib32-p11-kit-0.23.18.1-1  lib32-sdl-1.2.15-8
             lib32-v4l-utils-1.16.7-1  libgadu-1.12.2-9  libotr-4.1.1-2
             libvisual-0.4.0-7  nss-mdns-0.14.1-1  ocl-icd-2.2.12-3  openal-1.19.1-2
             opencl-headers-2:2.2.20170516-2  protobuf-3.10.0-1  protobuf-c-1.3.2-1
             pyopencl-headers-1:2019.1.1-1  python-beaker-1.11.0-1  python-cffi-1.13.0-1
             python-decorator-4.4.0-1  python-mako-1.0.14-1  python-markupsafe-1.1.1-1
             python-numpy-1.17.3-1  python-ply-3.11-2  python-pycparser-2.19-1
             python-pyopencl-1:2019.1.1-1  python-pytools-2019.1.1-1  qca-2.2.1-3
             qt5-declarative-5.13.2-1  qt5-location-5.13.2-1  qt5-multimedia-5.13.2-1
             qt5-script-5.13.2-1  qt5-sensors-5.13.2-1  qt5-svg-5.13.2-1
             qt5-webchannel-5.13.2-1  qt5-webkit-5.212.0alpha3-5  qt5-x11extras-5.13.2-1
             sdl-1.2.15-13  kadu-4.1-1  kadu-common-4.1-1  libkadu-4.1-1

Do pobrania:        189,52 MiB
Do zainstalowania:  737,01 MiB

:: Kontynuować instalację? [T/n] 

Taka duża ilość pakietów może występować tylko u mnie, ponieważ nie posiadam żadnego programu Qt

Prawdopodobnie pamac będzie chciał zaktualizować Kadu do wersji 4.3 lecz tej strony już nie a i my nie znależliśmy tej wersji więc jest to 4.1. Co by nie był caly czas czerwony dopisac trzeba do /etc/pacman.conf

 IgnorePkg=kadu

2lajki

@aquila, a można wiedzieć, jakiego forum i kto stworzył pakiet? Niekoniecznie z imienia, nazwiska i nr dokumentu, rzecz jasna.

forum.manjaro.pl - polskie wsparcie Manjaro. Hostowane przez: