Problem z programami do nagrywania ekranu

Hej mam dziwny problem z programami do nagrywania ekranu i nie potrafię sobię z tym poradzić.

https://youtu.be/805NPZjh3B0 - Nagranie z pulpitu

Dzieje się to samo ze wszystkimi programami z repo Manjaro. Używałem Peek / SSR / GTK i na wszystkich nagrania wyglądają ponownie. Co może być przyczyną takiego skakania okienek??

Trochę mało informacji, przydałoby się więcej informacji (przede wszystkim wynik inxi -Gxxx) ale na szczęście znalazłem podobny problem, więc nie zaszkodzi na początek skorzystać z tamtejszego rozwiązania. Należy zmienić w pliku /etc/X11/xorg.conf wartość AccelMethod na “uxa” (i odkomentować jeśli to konieczne). Jeśli nie masz u siebie takiego pliku, to wystarczy go utworzyć zgodnie ze wskazówkami z Arch Wiki.

@CalvinLanger
Czasami używam (i polecam) simplescreenrecorder z community lub vokoscreen z AUR i nie mam tego typu efektów.
Spróbuj, może u Ciebie też będzie OK.

@majo sęk w tym, że @CalvinLanger już używa SimpleScreenRecorder (na filmie) a problem i tak się pojawia. Podejrzewam, że wszystkie programy korzystają z tych samych mechanizmów i tylko interfejs jest inny. Więc jeśli problem leży tam, gdzie wskazałem, to zmiana raczej nie pomoże.

Próba utworzenia pliku

[calvinl@calvin-pc X11]$ sudo Xorg -configure
[sudo] hasło użytkownika calvinl: 
_XSERVTransSocketUNIXCreateListener: ...SocketCreateListener() failed
_XSERVTransMakeAllCOTSServerListeners: server already running
(EE) 
Fatal server error:
(EE) Cannot establish any listening sockets - Make sure an X server isn't already running(EE) 
(EE) 
Please consult the The X.Org Foundation support 
         at http://wiki.x.org
 for help. 
(EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
(EE) 
(EE) Server terminated with error (1). Closing log file.

inxi:

  Device-1: Intel 3rd Gen Core processor Graphics vendor: Lenovo 
  driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:0166 
  Device-2: NVIDIA GK107M [GeForce GTX 660M] vendor: Lenovo driver: N/A 
  bus ID: 01:00.0 chip ID: 10de:0fd4 
  Display: x11 server: X.Org 1.20.6 driver: none compositor: kwin_x11 
  tty: N/A 
  OpenGL: renderer: Mesa DRI Intel Ivybridge Mobile v: 4.2 Mesa 19.2.7 
  compat-v: 3.0 direct render: Yes

Czytaj ze zrozumieniem. W poleceniu zabrakło parametru wyświetlacza (bo na domyślnym już jest uruchomiona sesja X-ów). Spróbuj z sudo Xorg :2 -configure. Jeśli nadal nie zadziała spróbuj z inną cyferką lub podaj tutaj logi z pliku /var/log/Xorg.0.log. To polecenie utworzy ci plik xorg.conf.new w katalogu roota, który musisz skopiować do /etc/X11/ pod nazwą xorg.conf

Prośba, @CalvinLanger używaj znaczników kodu, zwiększy to czytelność.

forum.manjaro.pl - polskie wsparcie Manjaro. Hostowane przez: