Nie uruchamia mi się spotify

Mam problem z spotify nie chce się uruchomić a po wpisaniu w konsole wypluwa taki komunikat

tk-Message: 14:46:35.406: Failed to load module "canberra-gtk-module"
Pułapka debuggera/breakpoint (zrzut pamięci)

i nie wiem co mam z tym zrobić nie wie ktoś z was jak temu zaradzić
Z góry dziękuje!!!

Przede wszystkim sąd masz to Spotify – Snap, Flatpak czy AUR, a jeśli AUR to który konkretnie pakiet, bo jest ich kilka do wyboru.

Co do komunikatu to jest on powiązany z libcanberra – sprawdź, czy masz zainstalowane.

@BlackSky w profilu masz “inny system operacyjny”. Może warto napisać jaki to system.

1lajk

Instalowałem go przez Snap.
A a gdzie mogę to sprawdzić libcanberra

Jak to gdzie, wpisujesz w wyszukiwarkę pamaca i patrzysz czy jest zainstalowana. W twoim przypadku jednak to nic nie zmieni, bo Snap instaluje własne biblioteki i można jedynie czekać na aktualizację. Nie wiem, może są jakieś sposoby, by naprawić zepsutą aplikację ze Snapa, ja jednak takich nie znam. Rekomendowałbym instalację z Flatpaka lub z AUR.

OK, A jak odinstalować Snap.

@BlackSky to chyba oczywiste, tak jak instalowałeś, przypuszczam, że robiłeś to przez pamaca.

Dzięki za pomoc.
Na razie działa ale nie wiem na jak długo ale to nic.

W zasadzie, powinien działać i już. Manjaro wspiera Snap’a, więc:

  • aktualizuj system;
  • aktualizuj pakiety Snap:
    – używając Pamac’a (po doinstalowaniu odpowiedniego pakietu i włączeniu opcji w Pamac’u);
    – używając Bauh.
1lajk

forum.manjaro.pl - polskie wsparcie Manjaro. Hostowane przez: vpsadmin - hosting Discourse