Manjaro - Wine problem [KDE/PLASMA]

Witam
Mam problem z h3 hota i wine
Do tej pory wszystko działało elegancko po którejś aktualizacji coś się spaprało i wine nie reaguje. Po dwukliku na inkone H3 pokazuje się na moment ikonka wine przy kursorze na pasku zadań i zaraz znika. Wcześniej wszystko śmigało aż miło było popatrzeć
System aktualny wine też obecnie mam wine-staging 6.6.1 bo zwykłe wine nie działało ale objawy te same.
H3 na dysku z manjaro kopiowane nie instalowane (do tej pory wszystko działało updaty i reszta)
Żadnych błędów nie wywala
Proszę o pomoc

Może w takim razie warto wypróbować Lutrisa? Albo PlayOnLinux? Oba programy umożliwiają korzystanie z różnych wersji Wine.

Nie wiem xD
Zbadam programy dzięki

zobacz to może pomoże:

https://forum.winehq.org/viewtopic.php?f=8&t=34889

U mnie tez jest problem z wine. W grze Overlord 2 przestaly dzialac klawisze myszki, pomogla zmiana na zwykle wine. Niektore inne gry nadal sie nie uruchamiaja, mimo ze kiedys smigaly bez problemu.

Porąbane są te programy które podałeś
W playonlinux trzeba instalować grę nie można jej z dysku ruszyć (przynajmniej nie działa uruchom za pomocą)
Lutris też marne skutki przyniósł :confused:

W takim razie zainteresuj się tym wątkiem i tym rozwiązaniem – ostatnio niektórzy mają problemy z Mesą i Wine – sprawdź, czy masz takie same objawy:

To jest w sumie to samo co zaproponował @LinGruby


@peiner korzystasz z XWayland? Objawy pasują. Jeśli nie to też zainteresuj się wspomnianym wyżej rozwiązaniem albo starszymi wersjami Wine – czasem aktualizacje mogą wprowadzić regresje, wtedy najlepszym rozwiązaniem może być skorzystanie ze starszej wersji Wine.

Korzystam ze zwykłego xorga. U mnie problem jest trochę złożony, bo w dzień ostatniej aktualizacji wymieniłem mojego starego hdd na ssd w lapku i zainstalowałem Manjaro na nowo. Niestety nie mam jak cofnąć się do poprzednich wersji wine. Za pomocą winetricks zainstalowałem wszystko jak wcześniej. Próbowałem już tych opcji:

MESA_GL_VERSION_OVERRIDE=4.4
MESA_EXTENSION_MAX_YEAR=2001

Niestety bez żadnego skutku. Jedyne co przyniosło różnicę to zamiana wine-staging na zwykłe wine.

Nie wiem, jak i gdzie dokonywałeś tych ustawień, ale aby działały one globalnie, należy dopisać je np. do pliku /etc/environment
Spróbuj tam wpisać
MESA_GL_VERSION_OVERRIDE=4.5
(Z wartością =4.4 nie zawsze wszystko działa poprawnie.)

Zawsze robiłem skrypt który narzucał te wartości. Ten plik też mam już utworzony. Niestety, nic to nie zmieniło.

U mnie nie działa może robię coś nie tak poczekam aż naprawią w łatce :stuck_out_tongue:

Wraz z dzisiejszą aktualizacją problem u mnie minął. Dziękuje panie Manjaro :smiley:

Zgadzam się u mnie również wszystko wróciło do normy

forum.manjaro.pl - polskie wsparcie Manjaro. Hostowane przez: vpsadmin - hosting Discourse