Libre Office 6.2.0 problem z instalacją langpack


#1

Witajcie.
Nie jestem taki biegły i mam problem z zainstalowaniem langpack_pl z pliku deb które pobrałem ze strony https://pl.libreoffice.org/pobieranie/ do LibreOffice 6.2.0.3_1 z repo użytkowników Arch.
Użyłem oprogramowania debtab. W repo Arch nie ma langpack_pl do wersji 6.2.0. Czy ktoś z was może mi pomóc celem spolszczenia najnowszej wersji Libre Office?
Dzięki


#2

jakoś pakiet spolszczający jest jak do fresh tak i do still:

root at arch-bspwm: ~ - 23:14:05 [358] 
❯❯❯ pacman -Si libreoffice-fresh-pl
Repozytorium          : extra
Nazwa                 : libreoffice-fresh-pl
Wersja                : 6.2.0-1
Opis                  : Polish language pack for LibreOffice Fresh
Architektura          : any
Adres url             : http://www.documentfoundation.org
Licencje              : LGPL
Grupy                 : Brak
Dostarcza             : libreoffice-pl
Zależy od             : libreoffice-fresh
Opcjonalne zależności : Brak
Komfliktuje z         : libreoffice-pl
Zastępuje             : Brak
Do pobrania           : 2,25 MiB
Rozmiar po instalacji : 21,63 MiB
Autor pakietu         : Andreas Radke <andyrtr@archlinux.org>
Data zbudowania       : czw, 7 lut 2019, 13:58:51
Potwierdzone przez    : Suma MD5  Suma SHA256  Podpis

root at arch-bspwm: ~ - 23:14:42 [359] 
❯❯❯  pacman -Si libreoffice-still-pl
Repozytorium          : extra
Nazwa                 : libreoffice-still-pl
Wersja                : 6.1.5-1
Opis                  : Polish language pack for LibreOffice still
Architektura          : any
Adres url             : http://www.documentfoundation.org
Licencje              : LGPL
Grupy                 : Brak
Dostarcza             : libreoffice-pl
Zależy od             : libreoffice-still
Opcjonalne zależności : Brak
Komfliktuje z         : libreoffice-pl
Zastępuje             : Brak
Do pobrania           : 2,19 MiB
Rozmiar po instalacji : 22,15 MiB
Autor pakietu         : Andreas Radke <andyrtr@archlinux.org>
Data zbudowania       : czw, 7 lut 2019, 15:32:24
Potwierdzone przez    : Suma MD5  Suma SHA256  Podpis

root at arch-bspwm: ~ - 23:18:36 [360] 
❯❯❯

oczywiście w Arch :wink:


#3

W unstable są pakiety LO-6.2. Ściągnij i zainstaluj

sudo pacman -U pakiet

#4

Co Cię tak pili, co jest w tej najnowszej wersji, że nie możesz zaczekać dwóch tygodni i decydujesz się na kombinacje z .deb’em? Jeżeli będziesz instalował pakiety z pominięciem pacman’a, to możesz podmieniać współdzielone biblioteki (murowane problemy) lub pojawią się konflikty podczas aktualizacji systemu. Jak już tak bardzo zależy Ci na naaajaktualniejszości, to przejdź na unstable lub testing.


#5

Nie ukrywam, że tak dla zabawy :), a na zabawie człowiek najlepiej się uczy czegoś nowego :). Dzięki za wskazówki.


#6

Libre 6.2 jest już od jakiegoś czasu w gałęzi testing. Jak ci zależy to możesz chwilowo zmienić gałęzie. Nie ma w tej chwili żadnych większych problemów z pakietami w testing a że LO pociąga sporo dodatkowych zależności, lepiej od razu zaktualizować cały system. Czyli częściowej aktualizacji nie polecam w tym wypadku.

I jeśli się nie mylę LO powinno być na flatpaku lub snapie. Dużo łatwiejsza instalacja niż kombinowanie z debów.

Podejrzewam, że do dwóch tygodni LO 6.2 wyląduje w stable.


#7

Jeżeli możesz, to przenieś experymenty na osobną maszynę - będziesz mógł bawić się bezstresowo.
Co do .deb, to jeżeli o to Ci chodziło, to OK; ale jeżeli zależy Ci na świeżych pakietach, to - jak już było wcześniej wspomniane - zmiana gałęzi lub szukanie po kontenerach (snap, flatpak, appimage).