Laptop się nie włącza po uśpieniu Lenovo E540 Gnome 3.32

Witam
Koleżanki i koledzy mam problem z laptopem. Tak jak napisałem w temacie- Lenovo E540 z Gnomem nie włącza się po uśpieniu po otwarciu pokrywy. Usypia się normalnie ale później nie reaguje na nic. Trzeba wyłączyć go na twardo i włączyć od nowa. Kernel 4.19.32-1. Podpowiedzcie gdzie może być przyczyna?

Po co Tobie taki stary kernel?
Spróbuj na nowszym kernelu.

Ja mam Lenovo T 520 i najnowszy kernel. Wszystko działa bez zarzutu.

Zainstalowałem kernel 5.0.5-1 i to samo. Wcześniej próbowałem na różnych i też nie działało. Na windowsie usypianie i wybudzanie działa bez problemu na tym laptopie tylko z Manjaro jest problem… Ma ktoś może inny pomysł?

1 Like

Nie używam GNOME, ale mogę wskazać kierunek - przejrzyj konfigurację środowiska, pod względem elementów dotyczących zarządzania energią. Poexperymentuj z różnymi wariantami. Warto również zajrzeć do BIOS’u - to, że obecna jego konfiguracja sprawdza się z Windows’ami, nie znaczy, że będzie działać z innymi systemami.

@nikczemnik
z obserwacji i to bez wyjątku jakie distro zawsze były jakieś problemy z wybudzaniem
( większe lub mniejsze ) a i nie było ich w ogóle na to nie ma reguły :wink:

osobiście u siebie nigdy od 2007 jak zacząłem przygodę z Linux
Linux i tak szybko startuje a jak jest to jeszcze SSD to są to sekundy :wink:
nawet na HDD max 20-30s

to nie 2-3min jak miałem na Win jak jeszcze gościł u mnie na lapku…
teraz:

root at arch-bspwm: ~ - 14:31:01 [530] 
❯❯❯ systemd-analyze
Startup finished in 3.833s (kernel) + 6.424s (userspace) = 10.258s 
graphical.target reached after 6.424s in userspace
root at arch-bspwm: ~ - 14:31:04 [530] 
❯❯❯ 

przy prawie 20 programach startujących w tle :wink:

a biosem też się zainteresuj bo bios jest z reguły ustawiany dla Win ( bo dla firm to jest wykładnik ) którym w rzeczywistości nie jest :wink:

U mnie na HDD

Startup finished in 4.467s (kernel) + 13.128s (userspace) = 17.596s 
graphical.target reached after 13.127s in userspace

Fakt że gdy weszło jajko 5.0 to do wersji 5.0.5 system mi się uruchamiał w granicach od 28 do 30 s. ale teraz jest już wszystko w porządku.

@LinGruby, @robson75 -> wątek jest o wybudzaniu systemu z uśpienia, a nie o jego boot’owaniu.

przeczytaj mój ze zrozumieniem a potem wyciągaj wnioski, raz mało to dwa…

W końcu się udało- po zainstalowaniu sterów od Nvdia usypianie i budzenie działa:-).
Dzięki wszystkim za pomoc.

U mnie na Lenovo G585 i HDD

christophe@christophe-Lenovo-G585:~$ systemd-analyze Startup finished in 4.200s (firmware) + 5.470s (loader) + 13.716s (kernel) + 40.871s (userspace) = 1min 4.259s graphical.target reached after 32.432s in userspace
i ze środowiskiem Xfce po otwarciu pokrywy laptopa czasem też go trudno wybudzić z uśpienia. Nawet jak mam wygaszony ekran przy pomocy klawiszy funkcyjnych “Fn” to czasem też tak się dzieje

Radziłbym wpisać polecenie:
systemd-analyze blame
i sprawdzić jakie usługi są uruchamiane.

Miałem ostatnio podobny (ten sam?) problem na kilku instalacjach (nie wszystkich) i awaryjnie wyłączyłem light-locker (pomogło, inna blokada konsoli nie powoduje zawieszeń). Ale być może problem leży w driver’ach.