Konfiguracja GnuPG

Jednak wydzieliłem wątek. Tytuł jest nadmiarowy, ale nie miałem pomysłu na bardziej szczegółowy, który oddawał by istotę problemu.

Zaczęło się od:

potem było:

następnie:

i c.d.

Podaj zawartość gpg.conf :

cat /etc/pacman.d/gnupg/gpg.conf | grep 'keyserver '
keyserver-options timeout=10
keyserver-options import-clean
keyserver-options no-self-sigs-only

Hmmm, nie masz. A ja mam i niczego tam nie zmieniałem (data pliku = 2018-04-04). Muszę sprawdzić na nowszych instalacjach.

A jak, to wygląda u innych? Macie, panie i panowie, zdefiniowany server kluczy w gpg.conf? Wiem, że to lekki OT, więc jeżeli temat rozbuduje się, to wydzielę osobny wątek.

Hmm, u mnie na manjaro z marca 2019:

keyserver hkp://pool.sks-keyservers.net
keyserver-options timeout=10

mabox z sierpnia 2020:

keyserver-options timeout=10
keyserver-options import-clean
keyserver-options no-self-sigs-only

U mnie jest poprawnie:

cat /etc/pacman.d/gnupg/gpg.conf | grep 'keyserver '
keyserver hkp://pool.sks-keyservers.net

U mnie jest tak:

[tomek@tomek ~]$ ls -l /etc/pacman.d/gnupg | grep gpg.conf   
-rw-r--r-- 1 root root     114 2015-10-24  gpg.conf
[tomek@tomek ~]$ cat /etc/pacman.d/gnupg/gpg.conf
no-greeting
no-permission-warning
lock-never
keyserver hkp://pool.sks-keyservers.net
keyserver-options timeout=10

Plik siedzi ten sam od 5 lat – myślałem, że moja instalacja ma dopiero 4 lata, a tu taka niespodzianka :slight_smile:

GnuPG, to obszerny potwór (wystarczy spojrzeć do man’a lub na wiki Arch’a), więc podchodzę do niego z respektem i tylko do szczegółowych problemów.

Co zauważyłem, dotychczas?

  • konfiguracja GnuPG znajduje się w lokalizacji
    ~/.gnupg/
  • konfiguracja ‘prywatnego’ GnuPG dla Pacman’a znajduje się w
    /etc/pacman.d/gnupg/

A więc w tym przypadku, interesuje nas lokalizacja /etc/pacman.d/gnupg/.


— EDIT — a może i nie :slight_smile: bo przy ręcznym dodawaniu kluczy, być może brana pod uwagę jest konfiguracja z katalogu użytkownika. A w niej mam inny wpis:

~/.config/gnupg/gpg.conf
--------------------------------------------
keyserver hkp://keys.gnupg.net

a plik ma datę: 2019-09-09.


Z tego co widzę, to chyba w tym roku coś się zmieniło, ale tylko przy nowych instalacjach, bez automatycznej modyfikacji konfiguracji podczas update’u, czy dodawania .pacnew .

ta data nie do końca musi być właściwa. U mnie to polecenie pokazuje:

ls -l /etc/pacman.d/gnupg | grep gpg.conf
-rw-r--r-- 1 root root     141 2020-02-07  gpg.conf

co wskazuje na luty 2020, a to na pewno nie jest prawdą.
Natomiast to jest prawdą:

# tune2fs -l /dev/sda2 | grep 'Filesystem created'
[sudo] hasło użytkownika wiini2: 
Filesystem created:       Fri Aug  7 19:18:37 2020

Zatem może jednak to 4 lata, a nie 5 :wink:

Przepraszam, że tak trochę poa tematem.

Natomiast aby u mnie działało odświeżanie kluczy musiałem postąpić w ten sposób https://forum.archlinux.org.pl/viewtopic.php?pid=6399#p6399
Tyle że na Arch Linux.

No tak, masz rację. Wygłupiłem się :no_mouth:

forum.manjaro.pl - polskie wsparcie Manjaro. Hostowane przez: vpsadmin - hosting Discourse