KDE nie startuje do końca

Hej
Mam problem z KDE.
Raz na jakiś czas nie startuje - widać ekran startowy, potem czarne tło, ikona kosza i kursor. Kursorem można poruszać, nic nie można kliknąć.
Dziś zdarzyło się 3 razy pod rząd, potem już normalnie startował.

Czy może są jakieś logi do sprawdzenia? A może reset ustawień KDE pomoże?

Pozdrawiam

Mariusz

Logi zawsze warto sprawdzić, szukaj w journalctl wszelkich błędów.

Zanim zresetujesz wszystkie ustawienia, warto utworzyć nowego użytkownika i sprawdzić, czy tam ten problem też występuje – jeśli problem się nie pojawia to reset ustawień może być dobrą drogą.

  1. Logi o których wspomniał kolega @Tomek.
  2. Która wersja kernela.
  3. Jaka karta graficzna.
  4. Czy instalowałeś sterowniki i jakie.
    a) Sterowniki są wspierane na tym kernelu?
    b) Czy instalowałeś optimus-menager.

Co do podpunktu b) W moim przypadku stanowi problem na KDE poprzez czarny ekran w trakcie logowania na użytkownika (podczas startu systemu).
Jeśli nie możesz dostac się do logów, spróbuj:

  1. Odpalić Live USB.
  2. Zalogować się jako root sudo su podając hasło manjaro.
  3. Podmontować partycje z systemem mount -t /dev/sdX /mnt gdzie X to liczba/litera partycji, na której znajduje się zainstalowany system /.
  4. Wykonać chroot /mnt i dopiero journal -xe, lub inne funkcje które Cię interesują z logów z journal (link od @Tomek).

Założyłem nowe konto, wyłączyłem automatyczne logowanie. Teraz wybieram użytkownika “Mariusz”, KDE nie startuje, zamykam X (Ctr+Alt+Backspace) i wybieram “Mariusz2” i znów tylko ikona Kosza, kursor.
Włączyłem autostart Yakuake, i ona działa. Próbowałem

kstart5 plasmashell

Jest mnóstwo komunikatów, ale i tak nie startuje.

Przed tym poleceniem powinieneś ubić wszystkie dotychczasowe procesy Plasmy, a więc:

killall plasmashell

Przejrzałem trochę, jakie problemy z Plasmą przewijają się na głównym forum. Spora część wynika z tego, że mieszają pakiety -git ze zwykłymi. Warto sprawdzić, czy to również cię nie dotyczy, podaj wynik:

pamac list -i | grep plasma
pamac list -i | grep git

*extra-cmake-modules-git 5.77.0.r3206.g12e0189-1 community 846,7 kB
git 2.29.2-1 extra 31,9 MB
grub-theme-stylish-git 20200330-1 Repozytoria użytkowników Arch 3,3 MB
hardinfo-git 0.6.alpha.1330.g0557696-1 Repozytoria użytkowników Arch 3,0 MB
kcm-grub2-git 0.6.4.r86.g1912ede-1 Repozytoria użytkowników Arch 547,3 kB
kdsoap-ws-discovery-client git20200927-1 extra 961,1 kB
kqoauth-git 0.98.6.g7c31a12-1 Repozytoria użytkowników Arch 248,2 kB
libgit2 1:1.1.0-1 extra 1,9 MB
libkipi-git r1241.51e8206-1 Repozytoria użytkowników Arch 328,1 kB
libksane-git r470.5f53423-1 Repozytoria użytkowników Arch 407,9 kB
libkvkontakte-git r447.9ab8323-1 Repozytoria użytkowników Arch 247,7 kB
libmediawiki-git r122.858e4dc-1 Repozytoria użytkowników Arch 392,1 kB
samba-mounter-git 160.fe89aa7-1 Repozytoria użytkowników Arch 278,0 kB
smb4k-git 2.9.82.r146.9bb06e2-1 Repozytoria użytkowników Arch 5,3 MB
tifig-git r83.60b920c-1 Repozytoria użytkowników Arch 977,9 kB
zenstates-git

oraz

kdeplasma-addons 5.20.4-1 extra 5,5 MB
pamac-tray-icon-plasma 0.1.2-2 extra 35,0 kB
plasma-desktop 5.20.4-1 extra 33,5 MB
plasma-framework 5.76.0-1 extra 9,0 MB
plasma-integration 5.20.4-1 extra 450,6 kB
plasma-nm 5.20.4-1 extra 7,8 MB
plasma-pa 5.20.4-1 extra 856,0 kB
plasma-workspace 5.20.4-1 extra 39,5 MB
plasma-workspace-wallpapers 5.20.4-1 extra 46,6 MB
plasma5-applets-tiledmenu 41-1 Repozytoria użytkowników Arch 459,9 kB
plasma5-themes-breath 0.4.0-2 community 15,6 MB
plasma5-themes-breath2 1.0.10-2 community 11,1 MB
plasma5-themes-maia 1.2-1 community 1,3 MB

Całkiem możliwe, że coś jest na rzeczy. Plasmę masz normalną z repozytoriów + kilka rzeczy ze stajni KDE w wersji git i z AUR. Do wymiany lub usunięcia następujące pakiety:

libkipi-git       -->    libkipi
libksane-git      -->    libksane
libkvkontakte-git -->    libkvkontakte
libmediawiki-git  -->    libmediawiki
smb4k-git         -->    smb4k
samba-mounter-git
kcm-grub2-git

samba-mounter-git oraz kcm-grub2-git niestety nie mają odpowiedników w repozytoriach, więc pozostaje jedynie ich usunięcie. Jeśli jednak zależy ci na ich funkcjonalności to usuwałbym tylko jeśli wymiana pozostałych programów nic nie da.

plasma5-applets-tiledmenu – to kolejny potencjalny problem, w zależności skąd i czy w ogóle instalowałeś inne aplety. Dobra praktyka nakazuje brać je jedynie z jednego źródła, a więc albo instalujesz wszystkie aplety z repozytoriów/AUR, albo korzystasz tylko z managera rozszerzeń KDE. Nie należy mieszać tych dwóch źródeł.

Nie zawiesił się od 4 dni. Właściwe to usunąłem
plasma5-applets-tiledmenu

i zamieniłem:
libkipi
libksane
na normalne wersje.

Tiledmenu to strasznie mi szkoda - bardzo wygodne i ładne po prostu.

Dziękuje za pomoc.

forum.manjaro.pl - polskie wsparcie Manjaro. Hostowane przez: vpsadmin - hosting Discourse