Jak w Manjaro zainstalować Firefoxa 56.0?

Obecnie mam zainstalowany Firefox 83.0, chcę zaisntalować wersję 56.0 albowiem tylko tam działają mi starsze, potrzebne wtyczki. Skąd pobrać paczkę 56.0 i jak ją zainstalować ręcznie? W update jet tylko najnowsza wersja.

Drugie pytanie: czy w Manjaro da się użytkować kilka wersji Firefoxa tak aby nie kolodowały ze sobą profile? Jak to zrobić?

Nie muszę chyba pisać, że starsze wersje przeglądarek niosą ze sobą poważne ryzyko atakami takimi jak wirusy, trojany, phishing i inne. Ale jeśli koniecznie chcesz Firefox 56. Rozpakuj uruchom plik firefox. Powinien stworzyć własny profil i nie ingerować w wersję zainstalowaną w systemie. Swoją drogą to co to za dodatki, bez których nie możesz “żyć”?

PS. @piimaa witamy na forum.

Wprawdzie w AUR jest pakiet firefox56, jednak konfliktuje on z firefox (więc aktualny firefox zostałby odinstalowany, czego prawdopodobnie byś nie chciał).

W AUR jest także waterfox-classic-git w wersji 56, co prawdopodobnie odpowiada firefox w wersji 56 i może zadziałają tu twoje wtyczki.

W AUR jest także firefox-esr52 (odmiana firefox wersja 52), który nie konfliktuje z aktualnym firefox i i może zadziałają tu twoje wtyczki.

Instalowanie wprost starszego pakietu, niesie za sobą ryzyko nieprawidłowego działania, a nawet i nie działania w ogóle. Większość pakietów ma jakieś zależności i oczekuje, że będą to zależności w konkretnej wersji - zawsze najnowszej, dostępnej w repozytoriach systemowych. Jedynie słuszny i wspierany numer wersji, to najnowszy. Tak jest w dystrybucjach Arch-like i jeżeli, to Ci nie odpowiada, to musisz znaleźć inny system.

Dlatego, biorąc pod uwagę powyższe i zagrożenia, o których pisze @aquila, skłaniam się ku rozwiązaniu @majo, czyli waterfox-classic-git (zapewne również waterfox-classic-bin) lub firefox-esr52.

Budowanie tych pakietów (waterfox-classic i firefox-esr52) trwa w nieskończoność. Po 1.5h przerwałem. Pobrano z internetu przy budowie ponad 15GB i ciągle widniało: trwa budowanie pakietu.

Pytanie 2: jak przenieść gotowego Firefoxa 56 z Manjaro 16.01 do najnowszego? Da się?
Niby przeniosłem ale ciągle odpala mi 83.0 :smiley:

PS. Wtyczki firmowe, pisane przez śp.kolegę z pracy, nie ma update bo kolega katapultował się na tamten świat. Wtyczki współpracują z ftp w pracy, z minitoringiem online itp. WIęcej nic nei mogę napisać. Działają prawidłowo jedynie w Firefoksach do 56.0.1

Domyślam się, że wtyczki były pisane w XUL, a w takim razie spróbuj je zainstalować w Pale Moon (pakiet palemoon-bin z community). Jest szansa, że będą działać (nawet na aktualnym Pale Moon).

Na Pale Moon’ie powinny działać.
Poza tym, @piimaa, czytaj uważnie - sprawdziłeś waterfox-classic-bin. ‘-bin’ oznacza, że pakiet nie będzie się budował ze źródeł, tylko zostania przepakowany, już gotowy, pakiet debian’owy (na przykład) na arch’owy. Potrwa, to chwilę.

forum.manjaro.pl - polskie wsparcie Manjaro. Hostowane przez: vpsadmin - hosting Discourse