Intel - Obniżona wydajność (?)

Witam.

Na wstępie chciałbym zaznaczyć, że jestem początkujuącym użytkownikiem Manjaro, a co za tym idzie, prosiłbym o w miarę łopatoligiczne podejście do tłumaczenia.

Kilka dni temu, popełniłem mały błąd, dokonałem formatu systemu. System postawiłem na świeżo i teoretycznie, wszystko działało poprawnie, ale w momencie kiedy chciałem wrócić do rozgrywki w Morrowinda (OpenMW) doświadczyłem drastycznej róznicy w wydajnośći. Z stałych 60fps, przy odpalonym Vsync, natywnej rozdzielczośći - otrzymałem 5fps-30fps. Podobnie sprawa się ma w przypadku SWGemu, poprzedndnie, stałe 30fps - zamieniło się w 5fps-30fps, które skacze, niczym mała żabka. Poniżej zamieszczam przydatne informacje :

Karmel - 4.19.56- 1-Manjaro
CPU - Intel Core i5-4440 3.10GHz
GPU - Intel HD 4600

Zdaję sobię sprawę, że potrzebne będą dodatkowe informacje, ale nie jestem pewien które, a więc prosiłbym o ewentualnie wskazówki.

Pozdrawiam cieplutko :smile:

Wcześniej to też było Manjaro? Jakie sterowniki były wcześniej a jakie są teraz? Jakie miałeś wcześniej DE a jakie teraz?

Tak, wcześniej było Manjaro z Xfce, które jest również teraz. Odnośnie sterowników nie jestem pewny, wcześniej tego nie sprawdzałem, ale wydaje mi się, że były to raczej te same - Nic nie zmieniałem w systemie, ani teraz, ani wcześniej, były to identyczne instalacje.

inxi -Gxx

Graphics:
  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics 
  vendor: Gigabyte driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:0412 
  Display: x11 server: X.Org 1.20.5 driver: intel unloaded: modesetting 
  alternate: fbdev,vesa resolution: 1680x1050~60Hz 
  OpenGL: renderer: Mesa DRI Intel Haswell Desktop v: 4.5 Mesa 19.1.1 
  compat-v: 3.0 direct render: Yes 

mhwd -li

> Installed PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
           video-linux            2018.05.04                true            PCI


Warning: No installed USB configs!

Nie wiem czy i/lub jak objawia się podwójna karta graficzna, w sytuacji braku prawidłowych sterowników, dlatego zapytam, czy coś Ci na ten temat wiadomo, czy masz na pokładzie jedną, czy dwie karty graficzne?
(nawiasem … nie stawia się systemu na nowo, z powodu małego błędu)

lingruby at arch-bspwm: ~ - 20:52:13 [579] 
❯❯❯ inxi -Gxx 
Graphics:  Device-1: Intel Haswell-ULT Integrated Graphics vendor: Acer Incorporated ALI driver: i915 v: kernel 
           bus ID: 00:02.0 chip ID: 8086:0a16 
           Display: x11 server: X.Org 1.20.5 driver: intel compositor: compton resolution: 1366x768~60Hz, 1920x1080~60Hz 
           OpenGL: renderer: Mesa DRI Intel Haswell Mobile v: 4.5 Mesa 19.1.1 compat-v: 3.0 direct render: Yes 

ten

modesetting

dziwnie mi tu pasuje, ale co innego stock kernel a co innego jak u mnie zrobiony pod lapka i w grub włączone w /etc/default/grub

GRUB_CMDLINE_LINUX_DEFAULT="options i915.modeset=1 i915.fastboot=1 i915.enable_fbc=1 i915.enable_psr=0 i915.enable_ppgtt=0 enable_rc6=1 semaphores=1 libahci.ignore_sss=1 quiet"

po tym grub-mkconfig -o /boot/grub/grub.cfg

i reboot

a co do gier to się nie wypowiadam bo dla mnie komp służy do innych celów

Posiadam jedynie zintegrowany układ graficzny, ww. Intel HD 4600.

Małym błędem było sformatowanie niewłaściwiego dysku, czyste rozkojarzenie.

@LinGruby
Nie bardzo wiem, jak odnieść się, do Twojej wypowiedzi. Wykonałem to co wskazałeś, ale jedyny skutek, jedyny który zauważyłem, to dłuższe uruchomienie. Wyświetlnie GRUB w trakcie uruchamiania, a także informacja o hibernacji, ale nie jestem w stanie więcej powiedzieć - zbyt szybko znikało.

w piatce juz to jest “wbudowane” chyba …ps daj dmesg

to nie wiem Manjaro coraz bardziej mnie zadziwia…

u mnie start ( z około 20 programami w tle )

Startup finished in 4.037s (kernel) + 6.798s (userspace) = 10.835s 
graphical.target reached after 6.797s in userspace

Jest też możliwość wyłączenia tych wszystkich zabezpieczeń przed Spectre i Meltdown, ale odradzam i zrobiłbym to tylko wtedy gdy używasz tego komputera tylko do grania i niczego więcej. Zresztą patrząc na to, że jeszcze niedawno było dobrze przyczyna w 99% leży gdzieś indziej.

https://404.g-net.pl/2019/05/glupota-uszczesliwia-czyli-mam-gdzies-spectre-meltdown-i-mds/

Mhwd pokazuje, że masz sterowniki open source, duża szansa, że to jest przyczyną. Zainstaluj własnościowe sterowniki:

Zrób backup i miej live USB pod ręką a potem:

sudo mhwd -a pci nonfree 0300

i reboot.

Bądź ostrożny w stosowaniu się do dobrych rad (@LinGruby nie wyjaśnił, co znaczą poszczególne opcje), chyba że wiesz, co robisz.

Najważniejsze zdanie text’u, który linkujesz jest na końcu i brzmi:
Pytaniem otwartym pozostanie, czy było warto i kiedy zaczniemy tego żałować.

Czy w ogóle dostępne, są własnościowe driver’y do Intel’a, poza hybrydami?

$ mhwd -la
> All PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
   network-broadcom-wl            2018.10.07                true            PCI
         network-r8168            2016.04.20                true            PCI
     network-rt3562sta            2013.12.07                true            PCI
       network-slmodem            2013.12.07                true            PCI
             video-sis            2017.03.12                true            PCI
           video-linux            2018.05.04                true            PCI
          video-cirrus            2017.03.12                true            PCI
            video-i128            2017.03.12                true            PCI
             video-apm            2017.03.12                true            PCI
          video-voodoo            2017.03.12                true            PCI
             video-ast            2017.03.12                true            PCI
    video-nvidia-340xx            2018.08.09               false            PCI
    video-intel-gma500            2017.03.12                true            PCI
              video-s3            2017.03.12                true            PCI
          video-mach64            2017.03.12                true            PCI
      video-openchrome            2017.03.12                true            PCI
           video-tseng            2017.03.12                true            PCI
            video-tdfx            2017.03.12                true            PCI
         video-trident            2017.03.12                true            PCI
           video-glint            2017.03.12                true            PCI
             video-ark            2017.03.12                true            PCI
          video-vmware            2017.03.12                true            PCI
   video-siliconmotion            2017.03.12                true            PCI
video-hybrid-intel-nvidia-340xx-bumblebee            2018.08.09               false            PCI
      video-virtualbox            2018.11.25                true            PCI
             video-mga            2017.03.12                true            PCI
          video-savage            2017.03.12                true            PCI
           video-chips            2017.03.12                true            PCI
            video-i740            2017.03.12                true            PCI
        video-neomagic            2017.03.12                true            PCI
        video-catalyst            2017.03.12               false            PCI
          video-nvidia            2018.08.09               false            PCI
         video-s3virge            2017.03.12                true            PCI
            video-vesa            2017.03.12                true            PCI
       video-sisimedia            2017.03.12                true            PCI
          video-sisusb            2017.03.12                true            PCI
    video-nvidia-390xx            2018.08.09               false            PCI
video-hybrid-intel-nvidia-390xx-bumblebee            2018.08.09               false            PCI
       video-rendition            2017.03.12                true            PCI
           video-geode            2017.03.12                true            PCI
video-hybrid-intel-nvidia-bumblebee            2018.08.09               false            PCI
            video-r128            2017.03.12                true            PCI

Nie widzę.

Niestety zawsze używałem hybryd, więc też nie orientuję się w sterownikach intela, ale zakładam, że własnościowe istnieją, bo nikt nic nie wspomina ani nie rajcuje się open sourceowymi sterownikami w przeciwieństwie do AMD, ale mogę być w błędzie.

W ostateczności, mhwd poda, że nie ma nic do instalowania, więc nie zaszkodzi spróbować.

no to to już każdy sam sprawdzić co robi poszczególna opcja, wybacz wiem że to forum ale temat nie tyczy się żadnego poradnika ( w poradniku można acz nawet należy wytłumaczyć co dana opcja robi )

no ale teraz każdy czeka na gotowca etc. itp. ( a jak takiego nie dostanie możesz zebrać zje… )
już to przerabiałem, a każdy myślący user powinien zrobić kopie i po ewentualnych zmianach jak efekt nie został osiągnięty to powinien przywrócić stan przed zmianami itp.

jedyna opcja coby sterowniki zaszyte w kernelu działały poprawnie należy do /etc/X11/xorg.conf.d/
dodać 20-intel.conf o zawartości

  Section "Device"
    Identifier  "Intel Graphics"
    Driver      "intel"
    Option      "TearFree" "true"
    # Option      "AccelMethod"  "uxa"
    Option      "AccelMethod"  "sna"
    Option      "DRI"    "2"
    # Option      "DRI"    "3"
  EndSection

i reboot u mnie to dopiero sprawiło poprawne działanie sterowników intel więcej:

https://wiki.archlinux.org/index.php/Intel_graphics_(Polski)

Nie czepiam się tego, że nie opisałeś opcji. Moja uwaga była skierowana do @Martwy, aby nie wierzył na słowo i nie czynił na ślepo.