Brak możliwości bootowania z dysku usb

Witam zgłaszam się z zapytaniem, po instalacji Arch linux na dysku zewnętrznym usb laptop nie chce z tego dysku bootować, gdy wybiorę w boot menu dysk to z automatu bootuje z pierwszego dysk, jak ustawię ten dysk jako pierwszy to żaden system nie wstaje, system został zainstalowany prawidłowo, bo gdy podłączam dysk pod inny laptop to system bootuje, nie wiem na pewno co może być tego przyczyną?

[john@aza ~]$ inxi -Fxz
System:
  Kernel: 5.9.8-2-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  Desktop: KDE Plasma 5.20.3 Distro: Manjaro Linux 
Machine:
  Type: Laptop System: LENOVO product: 80TJ v: Lenovo ideapad 110-15ACL 
  serial: <filter> 
  Mobo: LENOVO model: Nano 5A8 v: SDK0J40700 WIN serial: <filter> 
  UEFI: Lenovo v: 1QCN16WW date: 03/24/2016 
Battery:
  ID-1: BATT charge: 19.2 Wh condition: 19.8/23.8 Wh (83%) 
  model: LENOVO LCFC status: Unknown 
CPU:
  Info: Quad Core model: AMD A6-7310 APU with AMD Radeon R4 Graphics 
  bits: 64 type: MCP arch: Puma rev: 1 L2 cache: 2048 KiB 
  flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 15974 
  Speed: 998 MHz min/max: 1000/2000 MHz boost: enabled Core speeds (MHz): 
  1: 1139 2: 1043 3: 1015 4: 1083 
Graphics:
  Device-1: AMD Mullins [Radeon R4/R5 Graphics] vendor: Lenovo 
  driver: radeon v: kernel bus ID: 00:01.0 
  Device-2: Acer EasyCamera type: USB driver: uvcvideo bus ID: 3-1.2:4 
  Display: x11 server: X.Org 1.20.9 driver: ati,radeon unloaded: modesetting 
  s-res: 3286x1080 
  OpenGL: renderer: AMD KABINI (DRM 2.50.0 5.9.8-2-MANJARO LLVM 11.0.0) 
  v: 4.5 Mesa 20.2.2 direct render: Yes 
Audio:
  Device-1: AMD Kabini HDMI/DP Audio vendor: Lenovo driver: snd_hda_intel 
  v: kernel bus ID: 00:01.1 
  Device-2: AMD FCH Azalia vendor: Lenovo driver: snd_hda_intel v: kernel 
  bus ID: 00:14.2 
  Sound Server: ALSA v: k5.9.8-2-MANJARO 
Network:
  Device-1: Realtek RTL8821AE 802.11ac PCIe Wireless Network Adapter 
  vendor: Lenovo driver: rtl8821ae v: kernel port: 2000 bus ID: 01:00.0 
  IF: wlp1s0 state: up mac: <filter> 
  Device-2: Realtek RTL810xE PCI Express Fast Ethernet vendor: Lenovo 
  driver: r8169 v: kernel port: 1000 bus ID: 02:00.0 
  IF: enp2s0 state: down mac: <filter> 
  Device-3: Microsoft Xbox 360 Wireless Adapter type: USB driver: xpad 
  bus ID: 2-1.1.1:5 
Drives:
  Local Storage: total: 1.95 TiB used: 48.27 GiB (2.4%) 
  ID-1: /dev/sda vendor: Silicon Power model: SPCC Solid State Disk 
  size: 476.94 GiB 
  ID-2: /dev/sdb vendor: A-Data model: SU800 size: 119.24 GiB 
  ID-3: /dev/sdc type: USB vendor: Western Digital 
  model: WD50 00LPCX-24VHAT0 size: 465.76 GiB 
  ID-4: /dev/sdd type: USB vendor: Seagate model: Expansion size: 931.51 GiB 
Partition:
  ID-1: / size: 116.38 GiB used: 23.17 GiB (19.9%) fs: ext4 dev: /dev/sdb2 
Swap:
  ID-1: swap-1 type: file size: 6.70 GiB used: 0 KiB (0.0%) file: /swapfile 
Sensors:
  System Temperatures: cpu: 36.0 C mobo: N/A gpu: radeon temp: 36.0 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 188 Uptime: 16h 26m Memory: 6.70 GiB used: 2.73 GiB (40.7%) 
  Init: systemd Compilers: gcc: 10.2.0 Packages: 1130 Shell: Bash v: 5.0.18 
  inxi: 3.1.08 

BIOS. Zależy czy nagrałeś obraz USB dla efi czy mbr. Na drugim kompie może być ustawiony tryb w jakim został nagrany ten obraz na USB.

Zmiana trybu UEFI na Legacy i odwrotnie nic nie daje, drugi komp wcale nie posiada Uefi bo tostary model lenovo, może trzeba by wyłączyć secury boot, ale nie wiem jak to zrobić?

Kombinuj w ustawieniach biosa, Tylko tam możesz wylączyć secure-boot.

@D35CART35 skonsultuj swój bios z checklistą – to też ładnie pokazuje różnicę w opcjach między starym bios a uefi, przy okazji dowiesz się co tak naprawdę masz :wink:

forum.manjaro.pl - polskie wsparcie Manjaro. Hostowane przez: vpsadmin - hosting Discourse