Błąd przy aktualizacji – Could not resolve host

Witam to u mnie takie cos wyskakuje

[wojcipat@wojcipat-pc ~]$ sudo pacman -Syu
:: Synchronizowanie baz danych z pakietami…
błąd:  nie udało się pobrać pliku 'core.db' z manjaro.barata.pt : Could not resolve host: manjaro.barata.pt
 core jest aktualne         0.0   B  0.00B/s 00:00 [----------------------]   0%
błąd:  nie udało się pobrać pliku 'extra.db' z manjaro.barata.pt : Could not resolve host: manjaro.barata.pt
 extra jest aktualne        0.0   B  0.00B/s 00:00 [----------------------]   0%
błąd:  nie udało się pobrać pliku 'community.db' z manjaro.barata.pt : Could not resolve host: manjaro.barata.pt
 community jest aktualne    0.0   B  0.00B/s 00:00 [----------------------]   0%
:: Some packages should be upgraded first...
rozwiązywanie zależności…
szukanie sprzecznych pakietów...

Pakiety (2) archlinux-keyring-20200108-1.0  manjaro-keyring-20190608-1

Do pobrania:             0.96 MiB
Do zainstalowania:       1.35 MiB
Zmiana po aktualizacji:  0.27 MiB

:: Kontynuować instalację? [T/n] T
:: Pobieranie pakietów…
błąd:  nie udało się pobrać pliku 'archlinux-keyring-20200108-1.0-any.pkg.tar.zst' z manjaro.barata.pt : Could not resolve host: manjaro.barata.pt
 archlinux-keyring-2...   868.3 KiB   931K/s 00:01 [######################] 100%
błąd:  nie udało się pobrać pliku 'manjaro-keyring-20190608-1-any.pkg.tar.xz' z manjaro.barata.pt : Could not resolve host: manjaro.barata.pt
 manjaro-keyring-201...   115.5 KiB  2.82M/s 00:00 [######################] 100%
(2/2) sprawdzanie kluczy w bazie                   [######################] 100%
(2/2) sprawdzanie spójności pakietów               [######################] 100%
błąd:  archlinux-keyring: podpis od "Andreas Baumann (sign) <mail@andreasbaumann.cc>" posiada nieznane zaufanie
:: Plik /var/cache/pacman/pkg/archlinux-keyring-20200108-1.0-any.pkg.tar.zst jest uszkodzony (Niepoprawny lub uszkodzony pakiet (podpis PGP)).
Czy chcesz go usunąć? [T/n] T
błąd:  nie udało się dokonać transakcji (Niepoprawny lub uszkodzony pakiet)
Wystąpiły błędy, nie zaktualizowano żadnego pakietu.

:: Rozpoczynanie pełnej aktualizacji systemu…
:: Zastąpić ilmbase przez extra/openexr? [T/n] T
:: Zastąpić pamac przez extra/pamac-gtk? [T/n] T
rozwiązywanie zależności…
szukanie sprzecznych pakietów...
błąd:  nie udało się przygotować transakcji (nie udało się rozwiązać zależności)
:: nie można spełnić zależności 'presentproto' wymaganej przez libxpresent
:: instalacja xorgproto (2019.2-2.0) uszkodzi zależności 'xf86miscproto' wymagane przez libxxf86misc

nie idzie usunac gdyz go nie ma a przy probie instalacji nie zaleznie jakiej aplikacji repezytoria itd dalej w/w komunikat pomoze ktos

@wojcipat

  1. Pisz po polsku, używaj interpunkcji.

  2. Masz skonfigurowany nieistniejący mirror o czym świadczy komunikat:

Could not resolve host: manjaro.barata.pt
  1. Wybierz inne mirrory i zaktualizuj system. Polecenie:
sudo pacman-mirrors --geoip && sudo pacman -Syyu
1lajk

Najwidoczniej “młode pokolenie” z komórką w dłoni 24/24 tak już ma, że piszą DZIWNIE

Nie tak mlode bo po 30 ale pisane na szybko po pracy oraz powrocie do Linuxa po kilka latach

no raczej po kilku latach


a co do tematu stosuję jedną zasadę którą wszczepił mi mój mentor od Linux’a ponad 10 lat temu:

szukaj, szukaj, czytaj, czytaj ( w necie jest wszystko ) no chyba że nie znajdziesz rozwiązania dopiero zadawaj pytania

i coby bardziej jeszcze w temacie zastanawia mnie nie aktywny mirror Manjaro skąd mógł się znaleźć u ciebie :wink:

Moja procedura aktualizacji obejmuje (między innymi):

  • aktualizację mirror’ów;
  • aktualizację baz;
  • aktualizację pakietów.

Zawsze i za każdym razem.

forum.manjaro.pl - polskie wsparcie Manjaro. Hostowane przez: