Błąd (JRE) przy otwieranie plików poprzez LibreOffice

Przy próbie otwierania plików w LibreOffice wyskakuje mi taki o to komunikat:
Do wykonania tej operacji LibreOffice wymaga środowiska Java (JRE). Wykryte środowisko JRE jest niepoprawne. Wybierz inną wersję JRE lub zainstaluj nową wersję i wybierz ją, klikając: Narzędzia - Opcje - LibreOffice - Zaawansowane.
W Narzędzia - Opcje - LibreOffice - Zaawansowane nie ma żadnej wersji Javy do wyboru.
Rozumiem, że powinienem zainstalować z repozytoriów, tylko który pakiet wybrać?

Jeśli to jest cały komunikat, jaki się pokazuje, to nie ma innego wyjścia jak zainstalować i przetestować pozostałe Javy. Nie powinny ze sobą konfliktować (przynajmniej te z repozytoriów – z AUR może być inaczej). Po zainstalowaniu powinny się pojawić w LO w Narzędzia - Opcje - LibreOffice - Zaawansowane – wybierasz, która cię interesuje i sprawdzasz, czy działa.

EDIT:

Z tego wynika, że najprawdopodobniej nie masz zainstalowanej żadnej Javy. Gdybyś miał to by się pokazała chociaż jedna opcja (czyli w zasadzie żaden wybór :stuck_out_tongue: ). Ja mam 8 i mi wszystko działa.

1lajk

Bez Javy również wszystko będzie działać. Prawie wszystko - Java potrzebna jest do paru funkcji, których najprawdopodobniej nie będziesz miał potrzeby wykorzystywać. Wystarczy w konfiguracji wyłączyć wykorzystywanie Javy (jedna z pierwszych rzeczy, jakie robię po zainstalowaniu Libre Office) i komunikat powinien zamknąć paszczę.

1lajk

nie praktykowałem tego i pamiętam z dawnych czasów na Windowsie podczas instalacji OpenOffice zawsze doinstalowywałem dodatkowy pakiet JRE. Ale Twój pomysł - może tez być OK.

1lajk

Jeżeli nie potrzebujesz funkcjonalności, do której Java jest potrzebna i nie potrzebujesz Javy do niczego innego, to nie ma sensu instalować. Oczywiście, zawsze można użyć argumentu ‘na wszelki wypadek’, ale wtedy - chcąc być konsekwentny - należałoby doinstalować parę tysięcy innych pakietów :smiley:

1lajk

… tylko do czego ONA potrzebna? jak pisze, że wymagana - to ja JĄ “załączam”

1lajk

Z help’u Libre Office:

‘Używaj środowiska Java
Umożliwia uruchamianie aplikacji i apletów języka Java w pakiecie LibreOffice. Kiedy aplikacja lub aplet Java próbuje uzyskać dostęp do dysku twardego, wyświetlane jest ostrzeżenie.’

1lajk

Ale którą zainstalować? Jest ich tam pełno.

Ja bym nie włączał obsługi Javy w Libre Office - ze względów bezpieczeństwa. Ale jeżeli bardzo chcesz, to instaluj bieżącą wersję:

$ pamac install jre-openjdk
1lajk

Dzięki, zainstalowało się. Java jest mi potrzebna (chyba) do działania Language Tool. Language Tool to dodatek, który odpowiada za sprawdzanie tekstów pod względem stylistycznym i gramatycznym. LT współpracuje też z wieloma przeglądarkami internetowymi. Świetna sprawa!

JRE nie jest przez Language Tool wymagane, tylko opcjonalne - do GUI. Ale, to dygresja, więc jej tutaj nie rozwijajmy.

forum.manjaro.pl - polskie wsparcie Manjaro. Hostowane przez: