Bardzo dziwny dźwięk wydobywający się z laptopa

Mam to tylko na Manjaro, na innych systemach cisza. Odłączyłem głośniki (fizycznie) aby namierzyć te pstrykanie i nic. Wentylator sprawdziłem, to nie on albowiem dźwięk słyszalny jest z całkiem innej strony. Sprawa dotyczy HP 820-G3 i okolic klawisza DELETE.
Dźwięk jest identyczny jak parkująca głowica w dysku HDD 2.5" tyle że jakieś 2,3x ciszej.
Pierwszy raz w życiu mam coś takiego że nie umiem znaleźć sprawcy :smiley: a siedzę w kompach od 1986r. Laptop był w mak rozkręcany juz dwa razy.
Dźwięk pojawia mi się 2,3 razy na godzinę, najczęściej przy obciążeniu ale to na bank nie wentylator. Odpinałem już klawiaturę i używałem inną na USB aby odczepić od problemu fakt, iż któreś klawisze mogą się przywieszać na tackach i produkować taki dźwięk.
Pisząc ten temat, przy wyrazie TACKACH ponownie usłyszałem dźwięk parkującej głowicy. Nie mam dysku HDD w środku, siedzi tam M2 PCIE oraz jeden SSD 2.5".
Miał ktoś z Was taką przygodę?
Co to może być?

Sprawdziłem płytę główną, nie widzę przepalonych ścieżek itp. Nic nie powinno syczeć i tak dalej. Obudowę przygniatałem w setkach miejsc setki razy, nic nie strzela, nic nie prycha. Zasilacz jest daleko, to nie on. Mam ducha w kompie kurcze… :smiley:

Spróbuj posłuchać tego dźwięku z różnych stron, tak aby na pewno prawidłowo go zlokalizować. Pomóc może ‘mikrofon kierunkowy’, czyli kartonowa rurka po papierze toaletowym lub papierowym ręczniku - im mniejsza średnica, tym bardziej precyzyjny pomiar. Dźwięk być może dochodzi z konkretnego miejsca, ale być może jest, to efektem jakiegoś odbicia lub złudzenia.

Warto również przyjrzeć się elektronice, pod kątem fizycznych możliwości generowania dźwięku - niezależnie od tego, co sądzi się na temat takiego prawdopodobieństwa.

Kondensatory tego typu na płycie głównej nie powinny wydawać takich dźwięków, choć, kto to wie… Jedynie co udało mi się zrobić to zlokalizować mniejsce tak na 95%, jest to okolica czytnika kart pamięci. Muszę go rozmontować w mak i uruchomić płyte na stole bez obudowy i reszty osprzętu i podziałać tak z dzionek, może coś to da.

Sprawozdawaj - ciekaw jestem, co to może być.

Znalazłem buga w Manjaro. Naciśnięcie przycisku wyłaczającego głośniki nie odłącza głośników. Na razie od wczoraj jest cisza, gdy głośniki fizycznie odłączone od płyty głównej. Właśnie je podłączyłem i pomimo tego że świeci się czerowna dioda (głośność wyłączona), słychać od czasu do czasu wspomniany wyżej dźwięk. Dopiero, odłącznie taśmy głośniczków zapodało ciszę. Od 5 rano męczę sprzęt na Mint’cie, Manjaro, Archu i Fedorze oraz testowo z Windows7 i 8.1. Tylko na Manjaro słychać ten dźwięk.
Teraz, muszę dotrzeć do przyczyny, przy czym dokładnie i kiedy to się dzieje czyli, na początek czeka mnie przeinstalowanie oprogramowania i sterowników (choć niby są najnowsze). Powyższe jest na HP 820-G3 oraz na HP 820-G2.
Natomiast na Lenovio L540 Manjaro syczy. Słychać non stop syczenie głośników, naciśnięcie przycisku wyłączającego AUDIO kończy owe syczenie.
Ewidentnie dzieje sie coś z oprogramowaniem i sterownikami, tyle że syczenie w Lenovo L540 jest także na Mint i innych. Nie ma tylko na Windowsach i tylko po zainstalowaniu sterowników producenta układu audio, na tych systmowych z windows syczenie nie ustaje.

Potwierdzam, prawy głośnik burczy pod Manjaro, dzieje się to w chwili klikania czegokolwiek na ekranie. Gdy nie klikam, jest cisza (klikanie myszką oraz pisanie na klawiaturze) albo… momentooo…
niech posłucham…

No nie, dźwięk słychać także gdy modem coś odbiera i wysyła.
Dwie godzinki sprawdzałem całość także na Mint 20.0.1, tam jest cisza.
Cyrk mam na Archu i Manjaro.

  • Warto również sprawdzić na zewnętrznych głośnikach i słuchawkach.
  • Brałbym pod uwagę zakłócenia elektryczne, jak i radiowe (mysz bezprzewodowa?)

Modem na oknie 2m od laptopa połączony przewodem usb 2m, mysz przewodowa, wszystko inne wokół wyłączone (telewizor+dekoder+audio). Zasilacz na podłodze, telefony na parapecie 3m dalej, szczerze mówiąc nie widzę nic nadprzeciętnie siejącego w okolicy. Instalacje elektryczną mam ok, uziemienie cacy, w lapku baterii nie ma.

Szukam dziury w całym, ale o to chodzi - jeżeli cyka na klikaniu myszy, to sprawdzić na innej oraz innych portach.

Na klikaniu myszy i klawiatury, inne klawiatury już sprawdzone, myszy też, wszędzie ten sam efekt.

Popróbuj z ustawieniami dźwięku. Na początek pavucontrol.

forum.manjaro.pl - polskie wsparcie Manjaro. Hostowane przez: vpsadmin - hosting Discourse