Animacja startowa (logo) przy boot w Manjaro

Trochę drażni mnie sposób uruchamiania systemu, mowa o Manjaro x64 z Xfce.
Nie mam ekranu logowania, 1 user więc od razu wskakuje pulpit. A co mnie drażni?
Mam Elitebooka 820-G2 i wygląda to tak:

  1. włączam kompa, jest logo HP (z UEFI jest załączony fastboot, boot trwa wtedy szybciej)
  2. po 1.5sek logo HP znika i gdy wiem już że system startuje to pojawia się ponownie lekko przyciemnione…
  3. potem mam czarny ekran przez 1sek
  4. następnie znowu logo HP…
  5. znowu czarny ekran przez 0.5sek i ponownie logo HP…
  6. całość trwa około 5-6sek od wciśnięcia POWER do pojawienia się PULPITU.

Powiem wprost, z deka mnie w… te mruganie logo HP!
System mam postawiony na GPT, ponoć w trybie UEFI.

Jak zmusić Manjaro do wyświetlenia jakiegoś (własnej roboty) logo od czasu startowania systemu do czasu uruchomienia pulpitu??
Byle co mi potrzebne, np. jakaś bitmapka która nie będzie kurdę mrugać czyli ciągle znikać i się pojawiać.

Trochę nietypowe zachowanie, normalnie po logu producenta powinno się pojawić logo Manjaro. Możliwe, że to kwestia ustawien Biosu – zajrzyj, może coś da się zmienić w tej kwestii.

Druga kwestia to bootsplash. Podrzucam podglądowy filmik z konfiguracji od @aquila, miej jednak na uwadze, że przez ten pewne rzeczy mogły ulec zmianie (sam niewiele jestem w stanie powiedzieć, nigdy nie czułem potrzeby kofiguracji bootsplash):

A jeśli interesuje cię całkowita pustka na ekranie to zajrzyj do artykułu o Silent boot :slight_smile:

Od tego posta w dół. Nic mi nie wiadomo, aby coś uległo zmianie. Używam na kilku maszynach, więc gdyby coś poszło nieprawidłowo, to daj znać - wypunktuję procedurę.


EDIT-20201119-2149 …
@Tomek, dałeś link do Plymouth, opisując go jako bootsplash.
Zapewne Plymouth mieści się w kategorii ‘bootsplash’, ale Bootsplash jako rozwiązanie obecne w kernel’u niewiele ma wspólnego z Plymouth. Moim zdaniem, należy zdecydowanie promować Bootsplash.

Przyznam szczerze że logo zniknęło mi od wersji chyba 19.0.1 w Manjaro. Zamast logo był tryb textowy a od wersji 20.X.X nie ma ani logo ani trybu tekstowego. Jest tylko czarny ekran. Mam tak na trzech laptopach, na HP 820-G2, na HP 8570p i na Lenovo L540. Myślałem że to twórcy Manjaro coś namieszali.
We wszystkich trzech przypadkach instalkę robię sobie Rufusem (klasycznie), startuje mi z EFI. Instalacja przebiegała normalnie bez niespodzianek.
Pokombinuję zaraz w biosie, może fastboot zwiechę złapał.
Ja nie używam Gruba do rozruchu, mam tak aby w przypadku awarii można było łatwo uruchamiać inne systemy. W Lenovo mam trzy dyski:

M2 + Manjaro
SSD + Mint
SSD + Win8 (wymagane przez pracę)

Wszystkie systemy instalowane były w trybie, w którym nie wiedziały co je czeka czyli montaż czystego M2 bez obecności innych dysków + instalacja Manjaro.
Następnie demontaż M2 i montaż SSD1 i instalacja Minta. Na koniec powtórka z rozrywki + montaż SSD3 i instalacja Win.
Dlaczego tak?
Włączam kompa, wciskam F11 i mam biosowe BootMenu. Tutaj wybieram sobie M2 lub SSD lub DVDRW. Ostatni dysk siedzi w miejscu nagrywarki w MultiBay więc wiem że pod menu DVDRW jest dysk z Windows. No i rozruch działa normalnie bez zabawy z Grubym i tak dalej. Można wyjmować dyski i bawić się na nich bez ingerencji w pozostałe systemy.

W przypadku Minta i Windows, loga startowe działają normalnie. Windows instalowany na GPT w trybie UEFI bootuje tak, że gdy pojawi się logo HP to pod nim pojawia się ten flash (kółeczko kręcące się) więc logo łapie od ręki. Mint ma podobnie, pojawia się logo HP a pod spodem napis linux loading… Jedynie Manjaro trochę dziwnie hula z tym odświeżaniem ekranu i wariacją z logo HP.

Od jakiegoś czasu ‘czarny ekran’ jest domyślnym ustawieniem w Manjaro - to nie ‘bag’ tylko ‘ficzer’. Dobry dla dysków SSD, bo boot’owanie trwa kilka sekund, ale dla talerzowych przydaje się jakiś ruch, umilający znacznie dłuższy start systemu.

Jak załączyć textowy boot?

Usuń quiet splash z poniższej lini w /etc/default/grub

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

Po edycji pliku wykonujesz plecenie sudo update-grub

U mnie jest tak:

GRUB_CMDLINE_LINUX_DEFAULT= “quiet apparmor=1 security=apparmor udev.log_priority=3”

Usuń quiet, wykonaj ‘$ sudo update-grub’ i powinieneś mieć komunikaty.
quiet wycisza komunikaty startowe, chyba że pojawiają się jakieś problemy.

forum.manjaro.pl - polskie wsparcie Manjaro. Hostowane przez: vpsadmin - hosting Discourse