RXTX uprawnienia do lock ?

#1

Witam.
Mam problem którego jakoś nie potrafię ogarnąć. Oto on.
Używam ups-a FSP a do niego oprogramowania ViewPower na linuxa które zawsze mi działało. Właśnie zmieniłem poczciwego laptopa hp na sony vaio ale pojawił się problem z obsługą tego programu jako normalny użytkownik. Pod kontem administratora wszystko działa jak należy.
Program odpala jakiś proces który przez gniazdo usb w trybie zwykłego portu szeregowego odczytuje parametry sieci zasilającej, stan akumulatora i inne bzdety które lubię sobie od czasu do czasu zobaczyć. Niestety obecnie pod odpaleniu w konsoli parametrów nie widać za to pojawia się komunikat :

check_group_uucp(): error testing lock file creation Error details:Brak dostępucheck_lock_status: No permission to create lock file.
please see: How can I use Lock Files with rxtx? in INSTALL

obecne konto sony zapisane do grup :

[sony@warsztat-pc ~]$ groups sony
wheel tty audio lp optical uucp video sys lock network scanner power sony

Czy dobrze kombinuję że jako sony nie mogę tworzyć w /run/lock ?

Ups razem z drukarką podłączony przez hub-a, drukarka działa bezproblemowo, z arduino też zero problemów. Jedyny problem to ten program który chodzi pod javą (arduino też).

#2

Cześć,
Brak uprawnień. Czy przeczytałeś zgodnie ze wskazówką pilik INSTALL?

#3

Ok, znalazłem w necie.

#4

Dodam od siebie jak ja używałem UPS to nigdy nie korzystałem z żadnych programów
podłączałem to co miałem do podłączenia i cała moja ingerencja w UPS
jedyne co zaobserwowałem to z czasem degradacja aku. żelowych w środku :wink:

Jak na początku UPS wytrzymywał 30 min. bez prądu o tyle pod koniec swojego żywota było to 5 min.
a nie był to nowy UPS tylko z odzysku ( bo nowy wytrzymywał 45 min )

Teraz zbieram wenę coby wymienić aku. żelowe i reanimować UPS :smiley:

#5

To powodzenia w wymianie bo ja sobie nie wyobrażam braku zasilania. Przy okazji mogę monitorować jakość napięcia zasilającego które zmienia się o kilkanaście woltów w ciągu 5 minut. Wcześniej nie zdawałem sobie z tego sprawy. Komunikat który podałem dalej się w konsoli wyświetla jednak program działa jak należy. Zainstalowałem w opt i uniknąłem spacji w nazwie.
Wcześniej instalowałem w katalogu domowym i zawsze działało teraz nie chce.
Zupełnie tego nie rozumiem.

#6

@warsztat-dom -> w /run/lock pisać może tylko owner, którym jest root.
Co znalazłeś w net’cie? Rozumiem, że rozwiązanie problemu - podziel się nim.

#7

plik INSTALL do poczytania :grinning: problem powstał bo zaszalałem i program umieściłem w nowym katalogu “Program files” a na jakimś forum przeczytałem że to błąd dla tego programu bo nie może być spacji w nazwie w ścieżce do niego, był to jakiś problem przez javę jak zapamiętałem ale nie znam się na tym