Problem z uśpieniem systemu w Manjaro

U mojej żony w laptopie występuje zjawisko, z którym dotychczas nie mieliśmy do czynienia. Otóż po zamknięciu klapy w laptopie lampka sygnalizująca uśpienie szybko miga, a po otwarciu klapy ekran jest czarny. Pomaga dopiero wyłączenie laptopa i ponowne jego włączenie.
Laptop Lenovo Thinkpad T520.
Macie jakieś sugestie jak to naprawić?

Już naprawiłem. Ustawiłem jak u siebie vm.swappiness=1 i migało, Zmieniłem na vm.swappiness=10 to przestało migać. Wszystko jest OK

Hmm, co ma jedno do drugiego? vm.swappiness reguluje intensywność wykorzystania swap’a. Nie twierdzę, że związku nie ma, tylko wyrażam swoje zdziwienie. Problem zaobserwowałem już kilka miesięcy temu (pisałem o tym w jakimś wątku) i dotyczy (nie)wychodzenia z uśpienia. Nie znalazłem rozwiązania. Nie działały również te z forów. Kto wie, może to jest TO. Przetestuję u siebie, w najbliższym czasie, i dam znać.

Niestety, to nie jest TO. Na chwilę się poprawiło i znowu jest to samo. Co najciekawsze, to że w Archu, który mam u siebie na takim samym lapku, wszystko działa poprawnie. Najwyraźniej są to dziwne maniery Manjaro :upside_down_face:

Fora dotyczące Manjaro nie uginają się pod ciężarem postów, opisujących ten problem. Oprócz Ciebie i mnie, spotkało coś podobnego jeszcze parę osób (sądząc po ilości wpisów), więc temat jest dość specyficzny. Zapewne spowodowany jakąś szczególną konfiguracją, jakiegoś pakietu lub funkcji, albo ich kombinacją. Nie dziwnymi manierami czegokolwiek.

No cóż… :roll_eyes:

a że tak zapytam co ma SWAP wspólnego z usypianiem systemu…


a co do problemu to jest to powiadomienie że system uśpiony dlatego miga i to jak dla mnie jest normalne


a u mnie zamknięcie klapy wyłącza tylko monitor ( lapek 24h ) a po co usypiać jak uruchamia się w ok. 9s :wink:

@LinGruby I cóż ja Ci na to wszystko poradzę :flushed:

jakie srodowisko graficzne? w jaki sposob jest usypiany? co odpowiada za zarzadzanie energia?

Środowisko graficzne Plasma.
Odpowiedź na drugie Twoje pytanie jest zawarta w pierwszym moim poście rozpoczynającym wątek. Warto chyba przeczytać. :wink:
Co odpowiada za zarządzanie energią? Nie mam pojęcia. Wiem tylko jedno, że niedawno ten problem u mojej żony nie występował, a teraz wielka trójca: Roland Singer, Guillaume Benoit, Philip Müller dorzuciła jakąś “wisienkę do tego tortu” i jest jak jest.

https://wiki.archlinux.org/index.php/Power_management/Suspend_and_hibernate
poverdevil zainstalowany? i systemctl status upower.service … kiedy ostatni raz sie zawiesil? journalctl --list-boots

Nie był uruchomiony upower.service (w moim Archu okazało się, że też). Tylko, że w moim Archu to zjawisko nie występowało.
> $ sudo journalctl --list-boots

-15 beaebd4564ec43d68ec8fb5b6c8d7569 Tue 2019-09-10 18:32:44 CEST—Tue 2019-09-10 18:52:18 CEST
-14 15ca7c31e47c45a89a12a1256c7caa45 Tue 2019-09-10 18:52:39 CEST—Tue 2019-09-10 19:51:47 CEST
-13 77bf20436cc24a469888bdd6d1522659 Tue 2019-09-10 19:52:10 CEST—Tue 2019-09-10 19:58:43 CEST
-12 019e55e6a28e4970a8a2614c914232db Tue 2019-09-10 19:59:06 CEST—Tue 2019-09-10 20:08:19 CEST
-11 447ff00e87774fba91eb51ceaa597b65 Tue 2019-09-10 20:09:01 CEST—Tue 2019-09-10 20:11:52 CEST
-10 10910c93f862425484e9743570e40d87 Tue 2019-09-10 21:03:10 CEST—Tue 2019-09-10 21:04:14 CEST
-9 7c4f1cae1fd94d9da88b5fc5e49fe995 Tue 2019-09-10 21:04:35 CEST—Wed 2019-09-11 00:07:14 CEST
-8 7fec6fe4179f4fe49bc90d61abe718f7 Wed 2019-09-11 07:43:28 CEST—Wed 2019-09-11 08:24:46 CEST
-7 37e83506aa134465bbc71714ec7cab4c Wed 2019-09-11 08:58:56 CEST—Wed 2019-09-11 14:03:16 CEST
-6 f2c268272e194d6e8c895b818f69c445 Wed 2019-09-11 14:15:50 CEST—Wed 2019-09-11 14:35:28 CEST
-5 e85ed15e54a743bd85992ea6d2524948 Wed 2019-09-11 17:29:35 CEST—Thu 2019-09-12 00:06:23 CEST
-4 d6e461180ed0450da42a88b677604f0b Thu 2019-09-12 09:06:57 CEST—Thu 2019-09-12 18:42:26 CEST
-3 719b7d43a24141eaad14315f95fdee77 Thu 2019-09-12 19:00:33 CEST—Thu 2019-09-12 23:43:34 CEST
-2 3662a9b78a7d491b8f193eeb974cc5ed Fri 2019-09-13 07:26:12 CEST—Fri 2019-09-13 17:08:19 CEST
-1 6250932a407e4acca9045dce28b3bfc5 Fri 2019-09-13 17:55:37 CEST—Sat 2019-09-14 00:33:26 CEST
0 644663242d714643b54e8cd6346c1226 Sat 2019-09-14 08:46:31 CEST—Sat 2019-09-14 08:54:56 CEST`


Nic nie pomogło włączenie upower.service. Nadal to się dzieje.

kiedy ostatnio sie zawiesil? data godzina? bo niezakumales ;D powerdevil zainstalowany? zainstaluj powerdevila i pojawia sie opcje konfiguracyjne w kcmshell5 - ustawienia systemowe ;D

On za każdym razem się zawiesza. Dzisiaj już ze trzy, czy cztery razy. Daty i godziny nie notuję, bo pewnie byłaby dosyć pokaźna publikacja. :upside_down_face:
Powerdevil zainstalowany od dawna. Wyobraź sobie, że zakumałem.:laughing:
Nie wiem o co Ci chodzi, bo w ustawieniach jest “Po zamknięciu pokrywy laptopa Uśpij”. Co tu zmieniać? Uruchomiłem kcmshell5, ale wysypała mi się pomoc do niego. Żadnych opcji ani ustawień nie było. Nigdy z tego nie korzystałem.

to wklej journalctl -b -1 … ten kcmshell5 to konsolowa nazwa - ustawien systemowych - niewazne hehe co do daty to chcialem poprostu loga zebys wkleil wtedy jak sie zawiesil…

A przez ten czas, to raz się nie zawiesił, a potem znów zawiesił. Obecnie wisi.

journalctl -b -1 pisalem …

Odwieszenie polega na jego wyłączeniu przyciskiem zasilania i na ponownym jego włączeniu. Skąd wziąć te logi??

Próbowałem odtworzyć twoją sytuację, ale mi się nie udało (nie korzystam z usypiania, a gdy włączyłem działało bez zarzutu). Upower.service miałem włączone. Poszukałem więc w sieci i znalazłem na głównym forum podobny problem, gdzie rozwiązano go przez instalację czegoś z AUR (nie wydaje mi się to mądre), ale niżej pod rozwiązaniem ktoś poradził, żeby wyedytować pliki systemd, pełna rada jest tutaj. U siebie nie znalazłem tych plików, ale znalazłem dwa pliki, które najprawdopodobniej odpowiadają u mnie za usypianie /etc/systemd/sleep.conf:

#  This file is part of systemd.
#
#  systemd is free software; you can redistribute it and/or modify it
#  under the terms of the GNU Lesser General Public License as published by
#  the Free Software Foundation; either version 2.1 of the License, or
#  (at your option) any later version.
#
# Entries in this file show the compile time defaults.
# You can change settings by editing this file.
# Defaults can be restored by simply deleting this file.
#
# See systemd-sleep.conf(5) for details

[Sleep]
#AllowSuspend=yes
#AllowHibernation=yes
#AllowSuspendThenHibernate=yes
#AllowHybridSleep=yes
#SuspendMode=
#SuspendState=mem standby freeze
#HibernateMode=platform shutdown
#HibernateState=disk
#HybridSleepMode=suspend platform shutdown
#HybridSleepState=disk
#HibernateDelaySec=180min

oraz /etc/systemd/system/sleep.target.wants/tlp-sleep.service:

# tlp - systemd suspend/resume service
#
# Copyright (c) 2019 Thomas Koch <linrunner at gmx.net> and others.
# This software is licensed under the GPL v2 or later.

[Unit]
Description=TLP suspend/resume
Before=sleep.target
StopWhenUnneeded=yes
Documentation=https://linrunner.de/tlp

[Service]
Type=oneshot
RemainAfterExit=yes
ExecStart=/usr/bin/tlp suspend
ExecStop=/usr/bin/tlp resume

[Install]
WantedBy=sleep.target

Jeśli u ciebie są jakieś różnice względem mnie to może w tym tkwi problem.

Akurat teraz uśpienie zadziałało, ale żona jest już w domu, to grzebać się w jej systemie teraz nie będę. Zobaczę później.
Dzięki za pomoc :slightly_smiling_face: